summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Wojdyła2025-03-17 22:52:04 +0100
committerMichał Wojdyła2025-03-17 22:52:04 +0100
commit894ee71d01ef49e8275d9ed94657f621648b5509 (patch)
treef9d94ae99eed9ac0aa6aa096314c0d5085265f5a
parent316947f976dd01d6fd2094401bbed6f82b7c1c16 (diff)
downloadaur-894ee71d01ef49e8275d9ed94657f621648b5509.tar.gz
update to 4.24.5
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a375d43015da..e11d4ae4f9df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-deal
pkgdesc = Design by contract for Python. Write bug-free code. Add a few decorators, get static analysis and tests for free
- pkgver = 4.24.4
+ pkgver = 4.24.5
pkgrel = 1
url = https://github.com/life4/deal
arch = any
@@ -20,7 +20,7 @@ pkgbase = python-deal
optdepends = python-hypothesis: for test generation
optdepends = python-pygments: for syntax highlighting in exceptions
optdepends = python-typeguard: for runtime type checking in tests
- source = python-deal-4.24.4.tar.gz::https://github.com/life4/deal/archive/4.24.4.tar.gz
- sha256sums = 4dee672a317d55216083155158617789c3f461b2c59911655e79fdd128bc4277
+ source = python-deal-4.24.5.tar.gz::https://github.com/life4/deal/archive/4.24.5.tar.gz
+ sha256sums = c5e4ac4012c3ccf54d80168b3b343c96024b9d0119b7b30e93675184b721b920
pkgname = python-deal
diff --git a/PKGBUILD b/PKGBUILD
index 7517eb37eeb6..1762c55144bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Carl Smedstad <carl.smedstad at protonmail dot com>
+# Contributor: Carl Smedstad <carl.smedstad at protonmail dot com>
pkgname=python-deal
_pkgname=${pkgname#python-}
-pkgver=4.24.4
+pkgver=4.24.5
pkgrel=1
pkgdesc="Design by contract for Python. Write bug-free code. Add a few decorators, get static analysis and tests for free"
arch=(any)
@@ -32,7 +32,7 @@ optdepends=(
# 'python-vaa: for supporting schemes (like marshmallow) as validators'
)
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('4dee672a317d55216083155158617789c3f461b2c59911655e79fdd128bc4277')
+sha256sums=('c5e4ac4012c3ccf54d80168b3b343c96024b9d0119b7b30e93675184b721b920')
_archive="$_pkgname-$pkgver"
@@ -52,7 +52,8 @@ check() {
--deselect tests/test_cli/test_test.py::test_print_exception \
--deselect tests/test_doctest.py::test_doctest \
--deselect tests/test_linter/test_extractors/test_exceptions_stubs.py::test_marhsmallow_stubs \
- --deselect tests/test_testing.py
+ --deselect tests/test_testing.py \
+ --deselect tests/test_linter/test_extractors/test_common.py::test_infer
}
package() {