summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Turner2017-01-04 20:27:28 -0500
committerWilliam Turner2017-01-04 20:27:28 -0500
commit667f12e47f762f77ee72735f79df1a11c608fa9b (patch)
treea4c0f101b8a34fb0f248d06baba9f9ed7a04ec44
downloadaur-667f12e47f762f77ee72735f79df1a11c608fa9b.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD50
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4144de862bb7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-defcon
+ pkgdesc = A set of UFO based objects for use in font editing applications.
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/typesupply/defcon
+ arch = any
+ license = MIT
+ makedepends = python-pip
+ makedepends = python2-pip
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/py2.py3/d/defcon/defcon-0.2.1-py2.py3-none-any.whl
+ sha256sums = 35adf23de9ebf4745e5084e777554f3073614a8ae76386cf78d886a516994639
+
+pkgname = python-defcon
+ depends = python
+ provides = python-defcon
+
+pkgname = python2-defcon
+ depends = python2
+ provides = python2-defcon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6794ff4f70a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: William Turner <willtur.will@gmail.com>
+pkgbase=python-defcon
+pkgname=(python-defcon python2-defcon)
+_pkgname=defcon
+pkgver=0.2.1
+pkgrel=1
+pkgdesc='A set of UFO based objects for use in font editing applications.'
+arch=('any')
+url='https://github.com/typesupply/defcon'
+license=('MIT')
+makedepends=('python-pip' 'python2-pip')
+options=(!emptydirs)
+source=("https://files.pythonhosted.org/packages/py2.py3/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}-py2.py3-none-any.whl")
+sha256sums=('35adf23de9ebf4745e5084e777554f3073614a8ae76386cf78d886a516994639')
+
+package_python-defcon() {
+ depends=('python')
+ provides=('python-defcon')
+
+ cd "${srcdir}"
+
+ # install the wheel
+ PIP_CONFIG_FILE=/dev/null pip install \
+ --isolated \
+ --root="${pkgdir}" \
+ --ignore-installed \
+ --no-deps \
+ ${_pkgname}-${pkgver}-py2.py3-none-any.whl
+
+ # compile to pyo
+ python -O -m compileall "${pkgdir}"
+}
+
+package_python2-defcon() {
+ depends=('python2')
+ provides=('python2-defcon')
+
+ cd "${srcdir}"
+
+ # install the wheel
+ PIP_CONFIG_FILE=/dev/null pip2 install \
+ --isolated \
+ --root="${pkgdir}" \
+ --ignore-installed \
+ --no-deps \
+ ${_pkgname}-${pkgver}-py2.py3-none-any.whl
+
+ # compile to pyo
+ python2 -O -m compileall "${pkgdir}"
+}