summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2021-07-21 05:15:00 -0400
committerGuillaume Horel2021-07-21 05:18:19 -0400
commitbb22124e0673e0c72df75ada36853997f5922f56 (patch)
tree2b668428566ca1fc613579df53c18845f93a0b55
parente7775c322e890b5e6ce065c943c8d93ba3208fa3 (diff)
downloadaur-bb22124e0673e0c72df75ada36853997f5922f56.tar.gz
fix build
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac627ca402a8..9cbb2c7ec1ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,9 +5,9 @@ pkgbase = python-defcon
url = https://github.com/robotools/defcon
arch = any
license = MIT
- checkdepends = python-pytest-runner
+ checkdepends = python-pytest
checkdepends = python-unicodedata2
- makedepends = python-setuptools-scm
+ makedepends = python-setuptools
depends = python-fonttools
depends = python-fs
optdepends = python-fontpens
@@ -16,4 +16,3 @@ pkgbase = python-defcon
sha256sums = 410adb6bd18996054ad82b0654aea2bc0a334a9ff7007fe983ec6f3f39f449ea
pkgname = python-defcon
-
diff --git a/PKGBUILD b/PKGBUILD
index ebb181953cb4..2d6be517f16e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,12 +10,16 @@ arch=('any')
url="https://github.com/robotools/$_pkgname"
license=('MIT')
depends=('python-fonttools' 'python-fs')
-makedepends=('python-setuptools-scm') # use -scm until upstream bug fixed https://github.com/robotools/defcon/issues/354
-checkdepends=('python-pytest-runner' 'python-unicodedata2')
+makedepends=('python-setuptools')
+checkdepends=('python-pytest' 'python-unicodedata2')
optdepends=('python-fontpens' 'python-lxml')
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.zip")
sha256sums=('410adb6bd18996054ad82b0654aea2bc0a334a9ff7007fe983ec6f3f39f449ea')
+prepare() {
+ sed -i '/setup_requires/d' "$_pkgname-$pkgver"/setup.{py,cfg}
+}
+
build() {
cd "$_pkgname-$pkgver"
python setup.py build
@@ -23,7 +27,7 @@ build() {
check() {
cd "$_pkgname-$pkgver"
- python setup.py test
+ pytest Lib/defcon/test
}
package() {