summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-05-31 15:52:38 +0300
committerCaleb Maclennan2020-05-31 16:10:09 +0300
commitecb9a2ba667825dbc24a925f593267834f975995 (patch)
tree77456c2986e521a2a46a0f334f6eb963c4e18e6b
parent7abda7cf73b83e16b3c796584be329169cd631e6 (diff)
downloadaur-ecb9a2ba667825dbc24a925f593267834f975995.tar.gz
upgpkg: python-defcon 0.7.2-2
* Split build()/install() stages as recommended in guidelines * Sort keys the order Arch wiki has them for easier comparing with -git * Use upstream project's repository as URL * Normalize shell quoting and variable syntax using shellharden
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD31
2 files changed, 22 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c55617c99cc4..e9805b84ddec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = python-defcon
pkgdesc = A set of UFO based objects for use in font editing applications
pkgver = 0.7.2
- pkgrel = 1
- url = https://pypi.org/project/defcon/
+ pkgrel = 2
+ url = https://github.com/robotools/defcon
arch = any
license = MIT
checkdepends = python-pytest
@@ -10,7 +10,7 @@ pkgbase = python-defcon
makedepends = python-setuptools
depends = python-fonttools
depends = python-fs
- depends = python>=3.8
+ depends = python
optdepends = python-fontpens
optdepends = python-lxml
source = https://pypi.org/packages/source/d/defcon/defcon-0.7.2.zip
diff --git a/PKGBUILD b/PKGBUILD
index ef5ded98f416..a5b086c568bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,33 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
-pkgname='python-defcon'
-_pkgname='defcon'
-pkgver='0.7.2'
-pkgrel=1
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+pkgname=python-defcon
+_pkgname=defcon
+pkgver=0.7.2
+pkgrel=2
pkgdesc='A set of UFO based objects for use in font editing applications'
-url="https://pypi.org/project/defcon/"
-checkdepends=('python-pytest' 'python-unicodedata2')
-depends=('python-fonttools' 'python-fs' 'python>=3.8')
+arch=('any')
+url="https://github.com/robotools/$_pkgname"
+license=('MIT')
+depends=('python-fonttools' 'python-fs' 'python')
makedepends=('python-setuptools')
+checkdepends=('python-pytest' 'python-unicodedata2')
optdepends=('python-fontpens' 'python-lxml')
-license=('MIT')
-arch=('any')
source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip")
sha256sums=('1967eaa23dcc8e1cbe3bd130aae4d9ddb72027b62d3e23eeb640065cfbd6d8d1')
+build() {
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
+
check() {
cd "$_pkgname-$pkgver"
python setup.py test
}
package() {
- cd "${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
- install -D -m644 License.txt "${pkgdir}/usr/share/licenses/${pkgname}/License.txt"
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" License.txt
}