summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2021-08-12 11:03:05 -0400
committerGI_Jack2021-08-12 11:03:05 -0400
commit7db35b3b83a93f7a49de6af557bd8f38ab5f9635 (patch)
treea831754873e534b6419eab091abc8ff988239e7f
downloadaur-7db35b3b83a93f7a49de6af557bd8f38ab5f9635.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD20
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0279f7f495c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo(replacement shim) v8
+# Thu Aug 12 11:02:55 AM EDT 2021
+pkgbase = delete-tweets
+ pkgdesc = a simple script that helps you delete tweets (or just replies or retweets) from your timeline
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://github.com/koenrh/delete-tweets
+ arch = any
+ license = custom:isc
+ makedepends = python-setuptools
+ depends = python
+ depends = python-twitter3
+ depends = python-dateutil
+ source = https://github.com/koenrh/delete-tweets/archive/refs/tags/v2.0.1.tar.gz
+ sha256sums = cf19eae62899ce4573136d5c59a26e4b600bdf03129766b826255f5b1ec2e382
+
+pkgname = delete-tweets
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05925ce1f36e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: GI_Jack <GI_Jack@hackermail.com>
+
+pkgname=delete-tweets
+_pkgname=delete-tweets
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="a simple script that helps you delete tweets (or just replies or retweets) from your timeline"
+url="https://github.com/koenrh/delete-tweets"
+arch=('any')
+license=('custom:isc')
+depends=('python' 'python-twitter3' 'python-dateutil')
+makedepends=('python-setuptools')
+source=("https://github.com/koenrh/delete-tweets/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('cf19eae62899ce4573136d5c59a26e4b600bdf03129766b826255f5b1ec2e382')
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}