summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2015-06-27 19:58:08 +0200
committerAdrian Perez de Castro2015-06-27 19:58:08 +0200
commit0bf59fde7bd8b607eab0ce8864229bea8fcb9745 (patch)
tree6ec59056fb7af1b16fa3e0f0d9875c2ee0695744
downloadaur-0bf59fde7bd8b607eab0ce8864229bea8fcb9745.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b011b83282e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-delorean
+ pkgdesc = Library providing a more convenient use of datetimes
+ pkgver = 0.4.5
+ pkgrel = 1
+ arch = any
+ license = custom:MIT
+ depends = python-pytz
+ depends = python-dateutil
+ source = https://pypi.python.org/packages/source/D/Delorean/Delorean-0.4.5.tar.gz
+ sha512sums = b40352f0605697ee7d18a95bf6b8f1cd882e18529a4d922aeca0eefa301ef0d191f3636c1b44d8e3e8a19e6dc0fc413a2a35f1d1e063f505a4688fda94369119
+
+pkgname = python-delorean
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2386735267a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
+_tarname='Delorean'
+pkgname='python-delorean'
+pkgdesc='Library providing a more convenient use of datetimes'
+pkgver='0.4.5'
+pkgrel='1'
+license=('custom:MIT')
+arch=('any')
+depends=('python-pytz' 'python-dateutil')
+source=("https://pypi.python.org/packages/source/D/Delorean/${_tarname}-${pkgver}.tar.gz")
+sha512sums=('b40352f0605697ee7d18a95bf6b8f1cd882e18529a4d922aeca0eefa301ef0d191f3636c1b44d8e3e8a19e6dc0fc413a2a35f1d1e063f505a4688fda94369119')
+
+package () {
+ cd "${_tarname}-${pkgver}"
+ python3 setup.py install --optimize=1 --root="${pkgdir}"
+ install -Dm644 LICENSE.txt \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}