summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuke Arms2021-12-29 15:16:05 +1100
committerLuke Arms2021-12-29 15:16:05 +1100
commit6ef121334c45efa5cf176fb22e6ff19bd8b48839 (patch)
treee95595043661f4410b7bc1c7d22435823b94fb7f
downloadaur-6ef121334c45efa5cf176fb22e6ff19bd8b48839.tar.gz
v3.0.5
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD28
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd617df7482e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-demjson3
+ pkgdesc = Fork of demjson to purely support Python 3. Python module for JSON data encoding, including jsonlint.
+ pkgver = 3.0.5
+ pkgrel = 1
+ url = https://github.com/nielstron/demjson3
+ arch = any
+ license = LGPL3
+ makedepends = python-setuptools
+ depends = python
+ provides = demjson
+ provides = python-demjson
+ conflicts = demjson
+ conflicts = python-demjson
+ conflicts = nodejs-jsonlint
+ source = https://files.pythonhosted.org/packages/source/d/demjson3/demjson3-3.0.5.tar.gz
+ sha256sums = ab9aabdd85695f3684fc296f39766a2730f6c8de81d23f7048073dfe2f616d80
+
+pkgname = python-demjson3
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..091d90939cd4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!*.patch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c086222764c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Luke Arms <luke@arms.to>
+# Contributor: Francois Garillot <francois[at]garillot.net>
+# Contributor: Massimiliano Torromeo <massimiliano.torromeo[@]gmail.com>
+pkgname=python-demjson3
+_pkgname=${pkgname#python-}
+pkgver=3.0.5
+pkgrel=1
+pkgdesc="Fork of demjson to purely support Python 3. Python module for JSON data encoding, including jsonlint."
+arch=('any')
+url="https://github.com/nielstron/demjson3"
+license=('LGPL3')
+depends=('python')
+makedepends=('python-setuptools')
+provides=('demjson' 'python-demjson')
+conflicts=('demjson' 'python-demjson' 'nodejs-jsonlint')
+sha256sums=('ab9aabdd85695f3684fc296f39766a2730f6c8de81d23f7048073dfe2f616d80')
+# https://warehouse.pypa.io/api-reference/integration-guide.html#querying-pypi-for-package-urls
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+
+build() {
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --prefix=/usr --optimize=1
+}