summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Harting2024-03-23 19:54:05 +0100
committerGiovanni Harting2024-03-23 19:54:05 +0100
commit0870d9a2c02843c1c86b570b6676fc0a9ef7ae2f (patch)
treeab0a4b0ea29e7c5be9b6cd7727038bae33a595e6
parentf23a121d79fd994c2d43e7d191c6f18d5e328146 (diff)
downloadaur-python-derpconf.tar.gz
upgpkg: python-derpconf 0.8.4-3
add missing dep; formatting
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9def62c065d7..7acd54f6c724 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-derpconf
pkgdesc = abstract loading of configuration files
pkgver = 0.8.4
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/globocom/derpconf
arch = any
license = MIT
@@ -10,7 +10,8 @@ pkgbase = python-derpconf
makedepends = python-wheel
makedepends = python-setuptools
depends = python
- source = https://github.com/globocom/derpconf/archive/0.8.4.tar.gz
+ depends = python-six
+ source = python-derpconf-0.8.4.tar.gz::https://github.com/globocom/derpconf/archive/0.8.4.tar.gz
b2sums = d0457481147a3ed8fa059f7022fede1577eca70a2818560e662715c58d995bee6a972925b01566d8f564f807ba8885a53a5e162de96f698ef9b7aaeb35f9da3b
pkgname = python-derpconf
diff --git a/PKGBUILD b/PKGBUILD
index 5a0b50c03ae8..2262b3db6e3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=python-derpconf
_name=${pkgname#python-}
pkgver=0.8.4
-pkgrel=2
-pkgdesc="abstract loading of configuration files"
+pkgrel=3
+pkgdesc='abstract loading of configuration files'
arch=(any)
-url="https://github.com/globocom/derpconf"
+url='https://github.com/globocom/derpconf'
license=(MIT)
-depends=(python)
+depends=(python python-six)
makedepends=(python-build python-installer python-wheel python-setuptools)
-source=("https://github.com/globocom/derpconf/archive/$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
b2sums=('d0457481147a3ed8fa059f7022fede1577eca70a2818560e662715c58d995bee6a972925b01566d8f564f807ba8885a53a5e162de96f698ef9b7aaeb35f9da3b')
build() {
@@ -21,7 +21,7 @@ build() {
package() {
cd $_name-$pkgver
python -m installer --destdir="$pkgdir" dist/*.whl
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
# vim:set ts=2 sw=2 et: