summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Harting2024-01-13 17:42:40 +0100
committerGiovanni Harting2024-01-13 17:42:40 +0100
commitf23a121d79fd994c2d43e7d191c6f18d5e328146 (patch)
treed6974097ae1eef38c906dff44645979b1ee77e03
parenta4dd41cd8e655f89b31bc3a761dfbe7395baddbb (diff)
downloadaur-f23a121d79fd994c2d43e7d191c6f18d5e328146.tar.gz
upgpkg: python-derpconf 0.8.4-2
switched to PEP 517
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce2b3c847548..9def62c065d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,13 @@
pkgbase = python-derpconf
pkgdesc = abstract loading of configuration files
pkgver = 0.8.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/globocom/derpconf
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-setuptools
depends = python
source = https://github.com/globocom/derpconf/archive/0.8.4.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 41c8a0e6c329..5a0b50c03ae8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,24 @@
pkgname=python-derpconf
_name=${pkgname#python-}
pkgver=0.8.4
-pkgrel=1
+pkgrel=2
pkgdesc="abstract loading of configuration files"
arch=(any)
url="https://github.com/globocom/derpconf"
license=(MIT)
depends=(python)
-makedepends=(python-setuptools)
+makedepends=(python-build python-installer python-wheel python-setuptools)
source=("https://github.com/globocom/derpconf/archive/$pkgver.tar.gz")
b2sums=('d0457481147a3ed8fa059f7022fede1577eca70a2818560e662715c58d995bee6a972925b01566d8f564f807ba8885a53a5e162de96f698ef9b7aaeb35f9da3b')
build() {
cd $_name-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd $_name-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}