summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaurizio D'Addona2023-05-11 15:13:48 +0200
committerMaurizio D'Addona2023-05-11 15:13:48 +0200
commit835eca0638e5b2350547bc0ed9a593f49ea302d6 (patch)
treefa57ccd43d3e99f8a09351a0f4b2c1e3944c27e0
parentb92cc7ba6e8f2f31b6701b0fa979ee7b2556de1e (diff)
downloadaur-835eca0638e5b2350547bc0ed9a593f49ea302d6.tar.gz
Updated to version 0.58.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--python-desispec-0.27.1.patch7
3 files changed, 8 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ece384db4b0e..2583f740e6df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-desispec
pkgdesc = Scripts and packages for building and running DESI spectroscopic analyses
- pkgver = 0.27.1
- pkgrel = 2
+ pkgver = 0.58.2
+ pkgrel = 1
url = https://github.com/desihub/desispec
arch = any
license = custom
@@ -14,9 +14,7 @@ pkgbase = python-desispec
depends = python-fitsio
depends = python-desiutil
depends = python-desimodel
- source = desispec-0.27.1::https://github.com/desihub/desispec/archive/refs/tags/0.27.1.tar.gz
- source = python-desispec-0.27.1.patch
- sha256sums = 673bc59f521074a6a237e72a2ed25972f8bd0dda341e9c81081f659a17646420
- sha256sums = 7c55008a7964ceaf8ba736999e4d15ba2837e3a05c8ace5a868dfe069d65421f
+ source = desispec-0.58.2::https://github.com/desihub/desispec/archive/refs/tags/0.58.2.tar.gz
+ sha256sums = a7dccdb6ab3e321e9c58873dbaa6daa20183804030b0d348f66f8dc1ecf52652
pkgname = python-desispec
diff --git a/PKGBUILD b/PKGBUILD
index 2d9a5f2160d7..6b9ae5e75f0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgname="desispec"
pkgname=python-desispec
-pkgver=0.27.1
-pkgrel=2
+pkgver=0.58.2
+pkgrel=1
pkgdesc="Scripts and packages for building and running DESI spectroscopic analyses"
arch=(any)
url="https://github.com/desihub/desispec"
@@ -12,15 +12,8 @@ depends=('python-requests' 'python-astropy' 'python-numba' 'python-healpy'
'python-speclite' 'python-sqlalchemy' 'python-fitsio'
'python-desiutil' 'python-desimodel')
-source=("$_pkgname-$pkgver"::"https://github.com/desihub/${_pkgname}/archive/refs/tags/${pkgver}.tar.gz"
- "$pkgname-$pkgver.patch")
-sha256sums=('673bc59f521074a6a237e72a2ed25972f8bd0dda341e9c81081f659a17646420'
- '7c55008a7964ceaf8ba736999e4d15ba2837e3a05c8ace5a868dfe069d65421f')
-
-prepare() {
- cd "$srcdir/${_pkgname}-$pkgver"
- patch --forward --strip=2 --input="${srcdir}/$pkgname-$pkgver.patch"
-}
+source=("$_pkgname-$pkgver"::"https://github.com/desihub/${_pkgname}/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('a7dccdb6ab3e321e9c58873dbaa6daa20183804030b0d348f66f8dc1ecf52652')
build() {
cd "$srcdir/${_pkgname}-$pkgver"
diff --git a/python-desispec-0.27.1.patch b/python-desispec-0.27.1.patch
deleted file mode 100644
index 401a9b51bc55..000000000000
--- a/python-desispec-0.27.1.patch
+++ /dev/null
@@ -1,7 +0,0 @@
---- src/desispec-0.27.1/py/desispec/maskbits.py 2022-03-07 15:06:49.000000000 +0100
-+++ src/desispec-0.27.1/py/desispec/maskbits.py 2022-03-07 15:06:54.000000000 +0100
-@@ -39,3 +39,3 @@
-
--_bitdefs = yaml.load("""
-+_bitdefs = yaml.safe_load("""
-#- CCD pixel mask