summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFred Lins2020-08-30 22:55:32 -0300
committerFred Lins2020-08-30 22:55:32 -0300
commitef8e765df5b74b761b58b6a9cf54e74b9144796a (patch)
treebc73ddf2f1d774c42305d93d832751f6dbe9cf53
downloadaur-ef8e765df5b74b761b58b6a9cf54e74b9144796a.tar.gz
Release 1.2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c58eec9e009
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-desktop-file
+ pkgdesc = Desktop-file is a tool to create desktop shortcuts for windows and linux.
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://github.com/PyRectangle/DesktopFile
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/PyRectangle/DesktopFile/archive/1.2.tar.gz
+ source = https://github.com/PyRectangle/DesktopFile/blob/master/LICENSE.md
+ sha256sums = 4ba309540068755349bae4ee99e7cd9e4ebe0144c95948d77492a090b6b6f333
+ sha256sums = 0980560df2c2133c47bd29d39d0f37276f57a54984d21a14b99ca74f986e9c54
+
+pkgname = python-desktop-file
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a5a6a1cd7d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer Fred Junior <fredcox@gmail.com>
+
+# pkgbase=pkgbase
+pkgname=python-desktop-file
+pkgver=1.2
+pkgrel=1
+arch=('any')
+pkgdesc="Desktop-file is a tool to create desktop shortcuts for windows and linux."
+url="https://github.com/PyRectangle/DesktopFile"
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://github.com/PyRectangle/DesktopFile/archive/$pkgver.tar.gz"
+ 'https://github.com/PyRectangle/DesktopFile/blob/master/LICENSE.md')
+sha256sums=('4ba309540068755349bae4ee99e7cd9e4ebe0144c95948d77492a090b6b6f333'
+ '0980560df2c2133c47bd29d39d0f37276f57a54984d21a14b99ca74f986e9c54')
+
+build() {
+ cd "DesktopFile-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ install -Dm644 LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ cd "DesktopFile-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}