summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2022-03-25 12:37:58 +0800
committerlilac2022-03-25 12:37:58 +0800
commit049a6544fdeb18a6518a2f981b38fa329d707a75 (patch)
tree2e713fa450654c57f1d5897ab8e0c1b59e18c487
parent727a6870ac66062b3e5721f35396c1c32f145559 (diff)
downloadaur-049a6544fdeb18a6518a2f981b38fa329d707a75.tar.gz
[lilac] updated to 0.6-3
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD7
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d27fe31140d0..731e536ce7f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-detectron2
pkgdesc = FAIR's next-generation platform for object detection and segmentation
pkgver = 0.6
- pkgrel = 1
+ pkgrel = 3
url = https://github.com/facebookresearch/detectron2
arch = x86_64
license = Apache
@@ -11,10 +11,12 @@ pkgbase = python-detectron2
depends = python-cloudpickle
depends = python-future
depends = python-fvcore
+ depends = python-hydra
depends = python-iopath
depends = python-matplotlib
depends = python-mock
depends = python-omegaconf
+ depends = python-opencv
depends = python-pillow
depends = python-pycocotools
depends = python-pydot
@@ -23,7 +25,6 @@ pkgbase = python-detectron2
depends = python-tqdm
depends = python-yacs
depends = tensorboard
- optdepends = opencv
source = detectron2-0.6.tar.gz::https://github.com/facebookresearch/detectron2/archive/v0.6.tar.gz
sha256sums = 9757fed05fa32acc2116ea038185f08409d5e854573e70f41909a358b70d1004
@@ -31,10 +32,12 @@ pkgname = python-detectron2
depends = python-cloudpickle
depends = python-future
depends = python-fvcore
+ depends = python-hydra
depends = python-iopath
depends = python-matplotlib
depends = python-mock
depends = python-omegaconf
+ depends = python-opencv
depends = python-pillow
depends = python-pycocotools
depends = python-pydot
@@ -50,10 +53,12 @@ pkgname = python-detectron2-cuda
depends = python-cloudpickle
depends = python-future
depends = python-fvcore
+ depends = python-hydra
depends = python-iopath
depends = python-matplotlib
depends = python-mock
depends = python-omegaconf
+ depends = python-opencv
depends = python-pillow
depends = python-pycocotools
depends = python-pydot
diff --git a/PKGBUILD b/PKGBUILD
index 445a1cc7df41..3640262b7404 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Butui Hu <hot123tea123@gmail.com>
-_CUDA_ARCH_LIST="5.2;5.3;6.0;6.1;6.2;7.0;7.0+PTX;7.2;7.2+PTX;7.5;7.5+PTX;8.0;8.0+PTX;8.6;8.6+PTX"
+_CUDA_ARCH_LIST="5.2;5.3;6.0;6.1;6.2;7.0;7.2;7.5;8.0;8.6;8.6+PTX"
pkgname=(python-detectron2 python-detectron2-cuda)
_pkgname=detectron2
pkgver=0.6
-pkgrel=1
+pkgrel=3
pkgdesc="FAIR's next-generation platform for object detection and segmentation"
arch=('x86_64')
url='https://github.com/facebookresearch/detectron2'
@@ -13,10 +13,12 @@ depends=(
python-cloudpickle
python-future
python-fvcore
+ python-hydra
python-iopath
python-matplotlib
python-mock
python-omegaconf
+ python-opencv
python-pillow
python-pycocotools
python-pydot
@@ -26,7 +28,6 @@ depends=(
python-yacs
tensorboard
)
-optdepends=('opencv')
makedepends=(
cuda
python-setuptools