summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2022-10-11 04:33:19 +0800
committerlilac2022-10-11 04:33:19 +0800
commit0a6c61f0dbbc9e62ed6df425a0b367f82bf88d51 (patch)
tree506d8839bad0edd8eab2371cb9645cb75c5b4813
parente8a3438ac9dd9b8dab110d53fe19a0ce48dafce8 (diff)
downloadaur-0a6c61f0dbbc9e62ed6df425a0b367f82bf88d51.tar.gz
[lilac] updated to 0.6-5
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6816c3c05221..d71755d838e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-detectron2
pkgdesc = FAIR's next-generation platform for object detection and segmentation
pkgver = 0.6
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/facebookresearch/detectron2
arch = x86_64
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index a630fd119f8d..6fca21dc540d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _CUDA_ARCH_LIST="5.2;5.3;6.0;6.1;6.2;7.0;7.2;7.5;8.0;8.6;8.6+PTX"
pkgname=(python-detectron2 python-detectron2-cuda)
_pkgname=detectron2
pkgver=0.6
-pkgrel=4
+pkgrel=5
pkgdesc="FAIR's next-generation platform for object detection and segmentation"
arch=('x86_64')
url='https://github.com/facebookresearch/detectron2'
@@ -56,6 +56,9 @@ package_python-detectron2() {
)
cd "${pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ # remove unused files
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ rm -rfv ${pkgdir}${site_packages}/tools
}
package_python-detectron2-cuda() {
@@ -69,5 +72,8 @@ package_python-detectron2-cuda() {
cd "${pkgname}-${pkgver}"
TORCH_CUDA_ARCH_LIST=${_CUDA_ARCH_LIST} \
FORCE_CUDA=1 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ # remove unused files
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ rm -rfv ${pkgdir}${site_packages}/tools
}
# vim:set ts=2 sw=2 et: