summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2020-12-02 19:51:02 +0800
committerlilac2020-12-02 19:51:02 +0800
commit0f54c355ca62b815ba4a0f1c126a0f30657f530b (patch)
tree8eff99092064ab689a76bf27e22c7e010459f241
parent2e7617f00d496ce2dc96670ecadba157bf650f68 (diff)
downloadaur-0f54c355ca62b815ba4a0f1c126a0f30657f530b.tar.gz
[lilac] updated to 0.3-2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0dfb0e818763..ef77c3a01424 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-detectron2
pkgdesc = FAIR's next-generation platform for object detection and segmentation
pkgver = 0.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/facebookresearch/detectron2
arch = x86_64
license = Apache
@@ -58,4 +58,6 @@ pkgname = python-detectron2-cuda
depends = tensorboard
depends = cuda
depends = python-pytorch-cuda
+ provides = python-detectron2=0.3
+ conflicts = python-detectron2
diff --git a/PKGBUILD b/PKGBUILD
index cf53f17d7dbb..21bfbf07b4da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=(python-detectron2 python-detectron2-cuda)
_pkgname=detectron2
pkgver=0.3
-pkgrel=1
+pkgrel=2
pkgdesc="FAIR's next-generation platform for object detection and segmentation"
arch=('x86_64')
url='https://github.com/facebookresearch/detectron2'
@@ -60,6 +60,8 @@ package_python-detectron2-cuda() {
cuda
python-pytorch-cuda
)
+ provides=(python-detectron2=${pkgver})
+ conflicts=(python-detectron2)
cd "${pkgname}-${pkgver}"
TORCH_CUDA_ARCH_LIST="5.2;5.3;6.0;6.0+PTX;6.1;6.1+PTX;6.2;6.2+PTX;7.0;7.0+PTX;7.2;7.2+PTX;7.5;7.5+PTX;8.0;8.0+PTX" \
FORCE_CUDA=1 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build