summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2023-03-13 20:36:25 +0800
committerlilac2023-03-13 20:36:25 +0800
commit47b2f6069f7cf15323153e67e59dd05098af0b56 (patch)
treeef12d3229506697504a5eb581550378f4b2e7157
parentc96f87562144fc64d42625273ebc30adf2d760d9 (diff)
downloadaur-47b2f6069f7cf15323153e67e59dd05098af0b56.tar.gz
[lilac] updated to 0.6-7
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 830b462cf3ac..43f6bb29de11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-detectron2
pkgdesc = FAIR's next-generation platform for object detection and segmentation
pkgver = 0.6
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/facebookresearch/detectron2
arch = x86_64
license = Apache
@@ -20,6 +20,7 @@ pkgbase = python-detectron2
depends = python-pillow
depends = python-pycocotools
depends = python-pydot
+ depends = python-sympy
depends = python-tabulate
depends = python-termcolor
depends = python-tqdm
@@ -41,6 +42,7 @@ pkgname = python-detectron2
depends = python-pillow
depends = python-pycocotools
depends = python-pydot
+ depends = python-sympy
depends = python-tabulate
depends = python-termcolor
depends = python-tqdm
@@ -62,12 +64,14 @@ pkgname = python-detectron2-cuda
depends = python-pillow
depends = python-pycocotools
depends = python-pydot
+ depends = python-sympy
depends = python-tabulate
depends = python-termcolor
depends = python-tqdm
depends = python-yacs
depends = tensorboard
depends = cuda
+ depends = libcudart.so
depends = python-pytorch-cuda
provides = python-detectron2=0.6
conflicts = python-detectron2
diff --git a/PKGBUILD b/PKGBUILD
index 0e6fa8448ee0..f9d5288aa95e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _CUDA_ARCH_LIST="6.0;6.1;6.2;7.0;7.2;7.5;8.0;8.6;8.6;8.9;9.0;9.0+PTX"
pkgname=(python-detectron2 python-detectron2-cuda)
_pkgname=detectron2
pkgver=0.6
-pkgrel=6
+pkgrel=7
pkgdesc="FAIR's next-generation platform for object detection and segmentation"
arch=('x86_64')
url='https://github.com/facebookresearch/detectron2'
@@ -22,6 +22,7 @@ depends=(
python-pillow
python-pycocotools
python-pydot
+ python-sympy
python-tabulate
python-termcolor
python-tqdm
@@ -65,6 +66,7 @@ package_python-detectron2-cuda() {
pkgdesc="${pkgdesc} (with CUDA)"
depends+=(
cuda
+ libcudart.so
python-pytorch-cuda
)
provides=(python-detectron2=${pkgver})