summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2021-03-09 17:43:02 +0800
committerlilac2021-03-09 17:43:02 +0800
commit7d0bd2946354b5454c8aa267fac265c268531dd0 (patch)
tree48d3d8c39bf71b4d8fe770904224b157a397b30f
parent0f54c355ca62b815ba4a0f1c126a0f30657f530b (diff)
downloadaur-7d0bd2946354b5454c8aa267fac265c268531dd0.tar.gz
[lilac] updated to 0.3-4
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef77c3a01424..c327507c9b4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-detectron2
pkgdesc = FAIR's next-generation platform for object detection and segmentation
pkgver = 0.3
- pkgrel = 2
+ pkgrel = 4
url = https://github.com/facebookresearch/detectron2
arch = x86_64
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index 21bfbf07b4da..64d8a9136a5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Butui Hu <hot123tea123@gmail.com>
+_CUDA_ARCH_LIST="5.2;5.3;6.0;6.1;6.2;7.0;7.0+PTX;7.2;7.2+PTX;7.5;7.5+PTX;8.0;8.0+PTX;8.6;8.6+PTX"
pkgname=(python-detectron2 python-detectron2-cuda)
_pkgname=detectron2
pkgver=0.3
-pkgrel=2
+pkgrel=4
pkgdesc="FAIR's next-generation platform for object detection and segmentation"
arch=('x86_64')
url='https://github.com/facebookresearch/detectron2'
@@ -42,7 +43,7 @@ build() {
python setup.py build
cd "${srcdir}/python-${_pkgname}-cuda-${pkgver}"
- TORCH_CUDA_ARCH_LIST="5.2;5.3;6.0;6.0+PTX;6.1;6.1+PTX;6.2;6.2+PTX;7.0;7.0+PTX;7.2;7.2+PTX;7.5;7.5+PTX;8.0;8.0+PTX" \
+ TORCH_CUDA_ARCH_LIST=${_CUDA_ARCH_LIST} \
FORCE_CUDA=1 python setup.py build
}
@@ -63,7 +64,7 @@ package_python-detectron2-cuda() {
provides=(python-detectron2=${pkgver})
conflicts=(python-detectron2)
cd "${pkgname}-${pkgver}"
- TORCH_CUDA_ARCH_LIST="5.2;5.3;6.0;6.0+PTX;6.1;6.1+PTX;6.2;6.2+PTX;7.0;7.0+PTX;7.2;7.2+PTX;7.5;7.5+PTX;8.0;8.0+PTX" \
+ TORCH_CUDA_ARCH_LIST=${_CUDA_ARCH_LIST} \
FORCE_CUDA=1 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}
# vim:set ts=2 sw=2 et: