summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2020-08-30 22:01:04 +0800
committerlilac2020-08-30 22:01:04 +0800
commite4d3f31b875c1159956684a1e9a3db7600dcacdf (patch)
treec60a13df910eae3ec4927812dc89a4b8332c8eff
parenta8d6a46c99028005a06ae52d00e2d431561c22e3 (diff)
downloadaur-e4d3f31b875c1159956684a1e9a3db7600dcacdf.tar.gz
[lilac] updated to 0.2.1-2
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD36
2 files changed, 64 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d800b1da224e..23bb16e00c55 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = python-detectron2
pkgdesc = FAIR's next-generation platform for object detection and segmentation
pkgver = 0.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/facebookresearch/detectron2
arch = x86_64
license = Apache
+ makedepends = cuda
makedepends = python-setuptools
+ makedepends = python-pytorch-cuda
depends = python-cloudpickle
depends = python-future
depends = python-fvcore
@@ -14,10 +16,8 @@ pkgbase = python-detectron2
depends = python-pillow
depends = python-pycocotools
depends = python-pydot
- depends = python-pytorch-cuda
depends = python-tabulate
depends = python-termcolor
- depends = python-torchvision
depends = python-tqdm
depends = python-yacs
depends = tensorboard
@@ -26,4 +26,36 @@ pkgbase = python-detectron2
sha256sums = ee3e404f534c03883423846876522d6b1e3e64796abd12caf51e8f8648bd5a63
pkgname = python-detectron2
+ depends = python-cloudpickle
+ depends = python-future
+ depends = python-fvcore
+ depends = python-matplotlib
+ depends = python-mock
+ depends = python-pillow
+ depends = python-pycocotools
+ depends = python-pydot
+ depends = python-tabulate
+ depends = python-termcolor
+ depends = python-tqdm
+ depends = python-yacs
+ depends = tensorboard
+ depends = python-pytorch
+
+pkgname = python-detectron2-cuda
+ pkgdesc = FAIR's next-generation platform for object detection and segmentation (with CUDA)
+ depends = python-cloudpickle
+ depends = python-future
+ depends = python-fvcore
+ depends = python-matplotlib
+ depends = python-mock
+ depends = python-pillow
+ depends = python-pycocotools
+ depends = python-pydot
+ depends = python-tabulate
+ depends = python-termcolor
+ depends = python-tqdm
+ depends = python-yacs
+ depends = tensorboard
+ depends = cuda
+ depends = python-pytorch-cuda
diff --git a/PKGBUILD b/PKGBUILD
index 923aeef42fa8..7fbc2e75d5f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Butui Hu <hot123tea123@gmail.com>
-pkgname=python-detectron2
+pkgname=(python-detectron2 python-detectron2-cuda)
_pkgname=detectron2
pkgver=0.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="FAIR's next-generation platform for object detection and segmentation"
arch=('x86_64')
url='https://github.com/facebookresearch/detectron2'
@@ -17,29 +17,51 @@ depends=(
python-pillow
python-pycocotools
python-pydot
- python-pytorch-cuda
python-tabulate
python-termcolor
- python-torchvision
python-tqdm
python-yacs
tensorboard
)
optdepends=('opencv')
makedepends=(
+ cuda
python-setuptools
+ python-pytorch-cuda
)
source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/facebookresearch/detectron2/archive/v0.2.1.tar.gz")
sha256sums=('ee3e404f534c03883423846876522d6b1e3e64796abd12caf51e8f8648bd5a63')
+prepare() {
+ cp -a "${_pkgname}-${pkgver}" "python-${_pkgname}-${pkgver}"
+ cp -a "${_pkgname}-${pkgver}" "python-${_pkgname}-cuda-${pkgver}"
+}
+
build() {
- cd "${_pkgname}-${pkgver}"
+ cd "python-${_pkgname}-${pkgver}"
+ python setup.py build
+
+ cd "${srcdir}/python-${_pkgname}-cuda-${pkgver}"
+ TORCH_CUDA_ARCH_LIST="5.2;5.3;6.0;6.0+PTX;6.1;6.1+PTX;6.2;6.2+PTX;7.0;7.0+PTX;7.2;7.2+PTX;7.5;7.5+PTX;8.0;8.0+PTX" \
FORCE_CUDA=1 python setup.py build
}
+package_python-detectron2() {
+ depends+=(
+ python-pytorch
+ )
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
-package() {
- cd "${_pkgname}-${pkgver}"
+package_python-detectron2-cuda() {
+ pkgdesc="${pkgdesc} (with CUDA)"
+ depends+=(
+ cuda
+ python-pytorch-cuda
+ )
+ cd "${pkgname}-${pkgver}"
+ TORCH_CUDA_ARCH_LIST="5.2;5.3;6.0;6.0+PTX;6.1;6.1+PTX;6.2;6.2+PTX;7.0;7.0+PTX;7.2;7.2+PTX;7.5;7.5+PTX;8.0;8.0+PTX" \
FORCE_CUDA=1 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}
# vim:set ts=2 sw=2 et: