summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjerry732042020-03-04 23:37:31 +0800
committerjerry732042020-03-04 23:37:31 +0800
commit2ea69c024d882b597e67cddbc5af61547803cf75 (patch)
tree015919645826078dc4d5d0578cb4bdee7ea67640
downloadaur-2ea69c024d882b597e67cddbc5af61547803cf75.tar.gz
Bump to r304.5e2a1ec-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c42f034c73b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-detectron2
+ pkgdesc = Detectron2 is Facebook AI Research's next generation software system that implements state-of-the-art object detection algorithms.
+ pkgver = r304.5e2a1ec
+ pkgrel = 1
+ url = https://github.com/facebookresearch/detectron2
+ arch = any
+ license = Apache-2.0
+ depends = python
+ depends = python-setuptools
+ depends = python-pytorch
+ depends = python-torchvision
+ depends = python-cocoapi
+ optdepends = opencv
+ provides = python-detectron2
+ source = detectron2::git+https://github.com/facebookresearch/detectron2.git
+ sha256sums = SKIP
+
+pkgname = python-detectron2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1423a72bccec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: jerry73204 <jerry73204@gmail.com>
+
+pkgname='python-detectron2'
+_reponame='detectron2'
+pkgver='r304.5e2a1ec'
+pkgrel='1'
+pkgdesc="Detectron2 is Facebook AI Research's next generation software system that implements state-of-the-art object detection algorithms."
+arch=('any')
+url='https://github.com/facebookresearch/detectron2'
+license=('Apache-2.0')
+provides=("${pkgname%-git}")
+depends=(
+ 'python'
+ 'python-setuptools'
+ 'python-pytorch'
+ 'python-torchvision'
+ 'python-cocoapi'
+)
+optdepends=('opencv')
+source=("${_reponame}::git+https://github.com/facebookresearch/detectron2.git")
+sha256sums=('SKIP')
+
+pkgber() {
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_reponame}"
+ python setup.py build
+}
+
+
+package() {
+ cd "${srcdir}/${_reponame}"
+ python setup.py install --root="${pkgdir}"/ --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}