summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-02-13 10:20:31 -0500
committerCarlos Aznarán2024-02-13 10:20:31 -0500
commitb2aba0f2302d10546ed926a0896caf3cd6b88fc0 (patch)
treedb55bcb994cb7125c7b9f56cb63d223ed9b4f4d8
downloadaur-b2aba0f2302d10546ed926a0896caf3cd6b88fc0.tar.gz
Bump version to 4.8.3
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD37
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7dc2589bdaa2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = python-devito
+ pkgdesc = Finite Difference DSL for symbolic computation
+ pkgver = 4.8.3
+ pkgrel = 1
+ url = https://github.com/devitocodes/devito
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ makedepends = openmp
+ depends = python-cached-property
+ depends = python-psutil
+ depends = python-py-cpuinfo
+ depends = python-codepy
+ depends = python-multidict
+ depends = python-anytree
+ depends = python-sympy
+ optdepends = python-mpi4py: for parallel support
+ optdepends = python-ipyparallel: for parallel support
+ source = devito-4.8.3.tar.gz::https://github.com/devitocodes/devito/archive/v4.8.3.tar.gz
+ sha512sums = d641d5546fd71a3b1b96358efd388eef1d4fe7d9825217ecd6992674ada2cc67bc32efb0af4361213ac4abc0eef89f10860a03ee5e6ebef8fba5a1951b0ef866
+
+pkgname = python-devito
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3aac8ed7d9e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+_base=devito
+pkgname=python-${_base}
+pkgver=4.8.3
+pkgrel=1
+pkgdesc="Finite Difference DSL for symbolic computation"
+arch=(any)
+url="https://github.com/${_base}codes/${_base}"
+license=(MIT)
+depends=(python-cached-property python-psutil python-py-cpuinfo
+ python-codepy python-multidict python-anytree python-sympy)
+makedepends=(python-build python-installer python-setuptools python-wheel openmp)
+# checkdepends=(python-pytest python-scipy python-matplotlib python-nbval python-cloudpickle)
+optdepends=('python-mpi4py: for parallel support'
+ 'python-ipyparallel: for parallel support') # python-click
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('d641d5546fd71a3b1b96358efd388eef1d4fe7d9825217ecd6992674ada2cc67bc32efb0af4361213ac4abc0eef89f10860a03ee5e6ebef8fba5a1951b0ef866')
+
+build() {
+ cd ${_base}-${pkgver}
+ DEVITO_ARCH=gcc DEVITO_MPI=1 python -m build --wheel --skip-dependency-check --no-isolation
+}
+
+# check() {
+# cd ${_base}-${pkgver}
+# python -m venv --system-site-packages test-env
+# test-env/bin/python -m installer dist/*.whl
+# DEVITO_ARCH=gcc DEVITO_MPI=1 OMP_NUM_THREADS=1 \
+# test-env/bin/python -m pytest tests/test_mpi.py \
+# -k 'not partitioning and not partitioning_fewer_dims and not partitioning_fewer_dims_timefunc and not neighborhood_horizontal_2d and not neighborhood_diagonal_2d and not ctypes_neighborhood and not custom_topology and not halo_exchange_bilateral and not halo_exchange_bilateral_asymmetric[paddings0] and not halo_exchange_bilateral_asymmetric[paddings1]'
+# }
+
+package() {
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}