summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-04-23 20:18:14 -0500
committerCarlos Aznarán2024-04-23 20:18:14 -0500
commitff50e56bd8fa3e9550054b787cf15fc593ee3864 (patch)
tree451603c8119b2b722ddc7dd5db2167de6b04c79b
parent2a9eed5216e6cb9489b9979317a2cf354da0f2f9 (diff)
downloadaur-ff50e56bd8fa3e9550054b787cf15fc593ee3864.tar.gz
Bump version to 4.8.5
-rw-r--r--.SRCINFO6
-rw-r--r--.nvchecker.toml5
-rw-r--r--PKGBUILD4
3 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9c3d1b2cdda..6085321b9485 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-devito
pkgdesc = Finite Difference DSL for symbolic computation
- pkgver = 4.8.4
+ pkgver = 4.8.5
pkgrel = 1
url = https://github.com/devitocodes/devito
arch = any
@@ -19,7 +19,7 @@ pkgbase = python-devito
depends = python-sympy
optdepends = python-mpi4py: for parallel support
optdepends = python-ipyparallel: for parallel support
- source = devito-4.8.4.tar.gz::https://github.com/devitocodes/devito/archive/v4.8.4.tar.gz
- sha512sums = f0f30ef248738adae46e94a5fa02f52ceb8b2d1e7eab2c202c428cdf049330568b5511fe1d0313eaefad065967816a0a8d84b0e02be67fa5ffbcb6f6589b6cec
+ source = devito-4.8.5.tar.gz::https://github.com/devitocodes/devito/archive/v4.8.5.tar.gz
+ sha512sums = adc2fd7b6f3aa577b3287132e37f64e9997e2694fc62bf48d8f968ee1b46746cdcd75470e20ae9cc02ec235f12815a0fd1cde80c4ea22160e23529e5c018359a
pkgname = python-devito
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..a0690556d822
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,5 @@
+[python-devito]
+source = "github"
+github = "devitocodes/devito"
+use_max_tag = true
+prefix = "v"
diff --git a/PKGBUILD b/PKGBUILD
index 61ffcc9f8ceb..62987fc53d0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
_base=devito
pkgname=python-${_base}
-pkgver=4.8.4
+pkgver=4.8.5
pkgrel=1
pkgdesc="Finite Difference DSL for symbolic computation"
arch=(any)
@@ -14,7 +14,7 @@ makedepends=(python-build python-installer python-setuptools python-wheel openmp
optdepends=('python-mpi4py: for parallel support'
'python-ipyparallel: for parallel support') # python-click
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('f0f30ef248738adae46e94a5fa02f52ceb8b2d1e7eab2c202c428cdf049330568b5511fe1d0313eaefad065967816a0a8d84b0e02be67fa5ffbcb6f6589b6cec')
+sha512sums=('adc2fd7b6f3aa577b3287132e37f64e9997e2694fc62bf48d8f968ee1b46746cdcd75470e20ae9cc02ec235f12815a0fd1cde80c4ea22160e23529e5c018359a')
build() {
cd ${_base}-${pkgver}