summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2020-01-08 15:40:03 +0200
committerChristoph Fink2020-01-08 15:40:03 +0200
commit0fdf9210a1f7ba44adfb13925a8bdd53b75a4374 (patch)
treedc2d0a846af4ca0a41d63d0ae271d2a88eff8693
parent1f55c17477a84e6ed82f67ba90bfb4a4b2e8cb55 (diff)
downloadaur-0fdf9210a1f7ba44adfb13925a8bdd53b75a4374.tar.gz
better PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24a09b8a29fc..b38b0c49b1e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-dhash
pkgdesc = Python library to calculate the difference hash (perceptual hash) for a given image, useful for detecting duplicates
pkgver = 1.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Jetsetter/dhash
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 36aeb04cac9a..14b8397a88e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=python-dhash
pkgname=('python-dhash' 'python2-dhash')
pkgver=1.3
-pkgrel=1
+pkgrel=2
pkgdesc="Python library to calculate the difference hash (perceptual hash) for a given image, useful for detecting duplicates"
url="https://github.com/Jetsetter/dhash"
@@ -17,21 +17,21 @@ source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_nam
sha256sums=("e6c8cd09d330f1ac44d3c9735d6b2a637d713dcb6b6091e340f91dda2484acb8")
prepare() {
- cp -a dhash-$pkgver{,-py2}
+ cp -a ${_name}-$pkgver{,-py2}
}
build() {
- cd "$srcdir"/dhash-$pkgver
+ cd "$srcdir"/${_name}-$pkgver
python setup.py build
- cd "$srcdir"/dhash-$pkgver-py2
+ cd "$srcdir"/${_name}-$pkgver-py2
python2 setup.py build
}
package_python-dhash() {
depends=('python' 'python-pillow')
- cd dhash-$pkgver
+ cd ${_name}-$pkgver
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.rst
}
@@ -39,7 +39,7 @@ package_python-dhash() {
package_python2-dhash() {
depends=('python2' 'python2-pillow')
- cd dhash-$pkgver-py2
+ cd ${_name}-$pkgver-py2
python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.rst
}