summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik Schwan2020-09-17 23:56:08 +0200
committerFrederik Schwan2020-09-17 23:56:08 +0200
commit6c0910fead58faad9e3e389671654dd58e016d20 (patch)
tree8430aa55a8d2257ef0059639845e330c61664e04
downloadaur-6c0910fead58faad9e3e389671654dd58e016d20.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e4565483e57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-diagnostics
+ pkgdesc = Module for logging of detailed traceback as HTML page - Alternative to Pythons module cgitb
+ pkgver = 0.2.4
+ pkgrel = 1
+ url = https://github.com/miso-belica/diagnostics
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ makedepends = python-pytest
+ makedepends = python-nose
+ depends = python
+ source = https://github.com/miso-belica/diagnostics/archive/v0.2.4/python-diagnostics-0.2.4.tar.gz
+ b2sums = e716828d9d8b7d6d54533b68090d6b14e4edbba5c732ac8687a6cf31e1debd431f9f7bfbc17b8305047556e765037c5f777c8f6e2b6f5f4f65803a17c96cc91d
+
+pkgname = python-diagnostics
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45aaae443b38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Frederik Schwan <freswa at archlinux dot org>
+
+pkgname=python-diagnostics
+pkgver=0.2.4
+pkgrel=1
+pkgdesc='Module for logging of detailed traceback as HTML page - Alternative to Pythons module cgitb'
+arch=('any')
+url='https://github.com/miso-belica/diagnostics'
+license=('GPL3')
+depends=('python')
+makedepends=('python-setuptools' 'python-pytest' 'python-nose')
+source=("https://github.com/miso-belica/diagnostics/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
+b2sums=('e716828d9d8b7d6d54533b68090d6b14e4edbba5c732ac8687a6cf31e1debd431f9f7bfbc17b8305047556e765037c5f777c8f6e2b6f5f4f65803a17c96cc91d')
+
+build() {
+ cd ${pkgname#python-}-${pkgver}
+ python setup.py build
+}
+
+check() {
+ cd ${pkgname#python-}-${pkgver}
+ python -m pytest
+}
+
+package() {
+ cd ${pkgname#python-}-${pkgver}
+ NO_THIRD_PARTY=true python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ install -Dm644 "${srcdir}"/${pkgname#python-}-${pkgver}/LICENSE.rst "${pkgdir}"/usr/share/licenses/${pkgname#python-}/LICENSE
+}