summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-12-03 09:00:58 +1300
committercaltlgin2020-12-03 09:00:58 +1300
commitc58572f3788e381c8dcfdd8b544931c748ee6808 (patch)
tree45c3f077e8a70fa136687d3f6c69a8ea6519f2e1
parent761e2ac0af1e8a308dfd24c7c1c5ccca46bbc429 (diff)
downloadaur-c58572f3788e381c8dcfdd8b544931c748ee6808.tar.gz
Python 3.9 rebuild
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD8
3 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5624af165dd0..f51c422b3464 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = python-dialite
pkgdesc = Lightweight pure-Python package to show simple dialogs
pkgver = 0.5.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/flexxui/dialite
arch = any
license = BSD
makedepends = python-setuptools
depends = python
- provides = dialite
source = https://files.pythonhosted.org/packages/source/d/dialite/dialite-0.5.3.tar.gz
sha256sums = de968f805fdc7f5545f15f5e17c2472198e0f6665b77f72be056f553d99292ef
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 1bc34da75a22..ed97e1530b24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
_pkgname='dialite'
pkgname="python-${_pkgname}"
pkgver=0.5.3
-pkgrel=1
+pkgrel=2
pkgdesc='Lightweight pure-Python package to show simple dialogs'
arch=('any')
url='https://github.com/flexxui/dialite'
+_url_pypi='https://pypi.org/project/dialite'
license=('BSD')
depends=('python')
makedepends=('python-setuptools')
-provides=("${_pkgname}")
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('de968f805fdc7f5545f15f5e17c2472198e0f6665b77f72be056f553d99292ef')
@@ -23,8 +23,8 @@ build() {
package() {
cd "${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" 'README.md'
- install -Dm644 -t "${pkgdir}/usr/share/licenses/${_pkgname}" 'LICENSE'
+ install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim: ts=2 sw=2 et: