summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonuk Raval2019-05-05 17:39:31 -0400
committerRonuk Raval2019-05-05 17:39:31 -0400
commitfba35b1bf866d23e200d2305ddb29e7e1d7b2ffe (patch)
tree9e603d840db0a91f90ecb713573c18ed0c92864e
downloadaur-fba35b1bf866d23e200d2305ddb29e7e1d7b2ffe.tar.gz
v0.5.2
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD27
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85239c05a6e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-dialite
+ pkgdesc = Lightweight pure-Python package to show simple dialogs.
+ pkgver = 0.5.2
+ pkgrel = 1
+ url = http://dialite.readthedocs.io/
+ arch = any
+ license = BSD
+ depends = python
+ source = python-dialite-0.5.2.tar.gz::https://github.com/flexxui/dialite/archive/v0.5.2.tar.gz
+ sha256sums = c730fdba77187a95529c88cf195e35ea8ce70ab012a98ad9b023ac39e93b62cd
+
+pkgname = python-dialite
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fe7fd49cca3b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg
+/src
+/*.pkg.tar
+/*.pkg.tar.xz
+/python-dialite-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ddb5eec2b70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Ronuk Raval <ronuk.raval at gmail dot com>
+
+pkgname=python-dialite
+pkgver=0.5.2
+pkgrel=1
+pkgdesc="Lightweight pure-Python package to show simple dialogs."
+arch=('any')
+url="http://dialite.readthedocs.io/"
+license=('BSD')
+depends=(python)
+source=(
+ ${pkgname}-${pkgver}.tar.gz::https://github.com/flexxui/dialite/archive/v${pkgver}.tar.gz
+)
+sha256sums=(
+ c730fdba77187a95529c88cf195e35ea8ce70ab012a98ad9b023ac39e93b62cd
+)
+
+build() {
+ cd "dialite-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "dialite-${pkgver}"
+ python setup.py install --skip-build --root="$pkgdir/" --optimize=1
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}