summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSZanko2021-02-04 19:50:40 +0100
committerSZanko2021-02-04 19:50:40 +0100
commit80dd7169ab0b5fc3c584d8ef88bd2f2e2c6b7daa (patch)
tree92e176488b328de2a27b25c522c33281d75bf004
parent21322bf0f05332f00af2cc8bd16d1b1055ebed9a (diff)
downloadaur-80dd7169ab0b5fc3c584d8ef88bd2f2e2c6b7daa.tar.gz
Updated to Version 0.8.1
Signed-off-by: SZanko <szanko@protonmail.com>
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD11
3 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec86cf7eb714..d1fa6fabc640 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-dictdiffer
pkgdesc = Dictdiffer is a library that helps you to diff and patch dictionaries
- pkgver = 0.7.1
+ pkgver = 0.8.1
pkgrel = 1
- url = https://github.com/openshift/openshift-restclient-python
+ url = https://github.com/inveniosoftware/dictdiffer
arch = any
- license = APACHE
+ license = MIT
makedepends = python-setuptools
depends = python
- source = https://files.pythonhosted.org/packages/source/d/dictdiffer/dictdiffer-0.7.1.tar.gz
- md5sums = e58fbec47e54ee4450bc768b08cb1ae4
+ source = https://files.pythonhosted.org/packages/source/d/dictdiffer/dictdiffer-0.8.1.tar.gz
+ md5sums = 3185fe683d976282bf6313de14b7c7e9
pkgname = python-dictdiffer
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1a4c07fb2ce2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/src/*
+/pkg/*
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index 1799f233239f..7913ac5c1a79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
-# Maintainer: Giacomo Longo <gabibbo97@gmail.com>
+# Maintainer: SZanko <szanko at protonmail dot com>
pkgname=python-dictdiffer
-pkgver=0.7.1
+pkgver=0.8.1
pkgrel=1
pkgdesc="Dictdiffer is a library that helps you to diff and patch dictionaries"
-url="https://github.com/openshift/openshift-restclient-python"
-license=('APACHE')
+url="https://github.com/inveniosoftware/dictdiffer"
+license=('MIT')
_name=${pkgname#python-}
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
arch=('any')
makedepends=('python-setuptools')
depends=('python')
+md5sums=('3185fe683d976282bf6313de14b7c7e9')
build() {
cd "$srcdir/$_name-$pkgver"
@@ -19,5 +20,5 @@ build() {
package() {
cd "$srcdir/$_name-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
-md5sums=('e58fbec47e54ee4450bc768b08cb1ae4')