summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-08-16 18:25:28 -0500
committerCarlos Aznarán Laos2022-08-16 18:25:28 -0500
commit31088031a8dd6ea7ef1183ba678ac82675304a5c (patch)
treee925c33794fe1a43c426b12136d7a2c70b82d964
parent4889304a463843ee6966bd6078f603247805b083 (diff)
downloadaur-31088031a8dd6ea7ef1183ba678ac82675304a5c.tar.gz
Rewrite source array
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD30
2 files changed, 20 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a17346a71c8..32e4cb0e7d0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,12 @@
-# Generated by mksrcinfo v8
-# Sun Feb 26 22:22:41 UTC 2017
pkgbase = python-dicttoxml
- pkgdesc = Converts a Python dictionary or other native data type into a valid XML string.
+ pkgdesc = Converts a Python dictionary or other native data type into a valid XML string
pkgver = 1.7.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/quandyfactory/dicttoxml
arch = any
license = GPL
depends = python
- source = https://pypi.python.org/packages/74/36/534db111db9e7610a41641a1f6669a964aacaf51858f466de264cc8dcdd9/dicttoxml-1.7.4.tar.gz
- md5sums = ec5643a048cf32dad3c28db236b923e4
+ source = https://pypi.org/packages/source/d/dicttoxml/dicttoxml-1.7.4.tar.gz
+ sha512sums = 91abcf2b9b248717618e9fc1c8694e881b9deaa16438dd4674f94a22b4aabfdab3b13f95c3d44a60577d49eca82fb268f59b33d1312cf5388bdaf949a2865cbf
pkgname = python-dicttoxml
-
diff --git a/PKGBUILD b/PKGBUILD
index ec8edecc51b8..0eb4d280b452 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
# Maintainer: Jose Riha <jose1711 gmail com>
-# Automatically generated by pip2arch on 2017-02-26
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
-pkgname=python-dicttoxml
+_base=dicttoxml
+pkgname=python-${_base}
+pkgdesc="Converts a Python dictionary or other native data type into a valid XML string"
pkgver=1.7.4
-pkgrel=1
-pkgdesc="Converts a Python dictionary or other native data type into a valid XML string."
-url="https://github.com/quandyfactory/dicttoxml"
-depends=('python')
-license=('GPL')
-arch=('any')
-source=('https://pypi.python.org/packages/74/36/534db111db9e7610a41641a1f6669a964aacaf51858f466de264cc8dcdd9/dicttoxml-1.7.4.tar.gz')
-md5sums=('ec5643a048cf32dad3c28db236b923e4')
+pkgrel=2
+arch=(any)
+url="https://github.com/quandyfactory/${_base}"
+license=(GPL)
+depends=(python)
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
+sha512sums=('91abcf2b9b248717618e9fc1c8694e881b9deaa16438dd4674f94a22b4aabfdab3b13f95c3d44a60577d49eca82fb268f59b33d1312cf5388bdaf949a2865cbf')
build() {
- cd $srcdir/dicttoxml-1.7.4
- python setup.py build
+ cd ${_base}-${pkgver}
+ python setup.py build
}
package() {
- cd $srcdir/dicttoxml-1.7.4
- python setup.py install --root="$pkgdir" --optimize=1
+ cd ${_base}-${pkgver}
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENCE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
}