summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-05-06 07:39:27 -0500
committerCarlos Aznarán Laos2023-05-06 07:39:27 -0500
commit78478e430b64c11dd3499598db54d21cdf5ca315 (patch)
tree177ca5d1fbb83f9836b0d91cf2da1b90b82c357b
parent3a70b61b6f8dabca2a081ee6d22388555d866c93 (diff)
downloadaur-78478e430b64c11dd3499598db54d21cdf5ca315.tar.gz
Python 3.11 rebuild
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5dc6649cd6fa..1d6025fe03a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,10 @@ pkgbase = python-dicttoxml
url = https://github.com/quandyfactory/dicttoxml
arch = any
license = GPL
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
depends = python
source = https://pypi.org/packages/source/d/dicttoxml/dicttoxml-1.7.16.tar.gz
sha512sums = ac9d5b0f8acd0a18f918309cacba131843feebd6ad7c94935062d6e1ed7b529c5b91d6a9b65787647f73616e974d0599e8515bb07d69b036483d3a733e4dec6a
diff --git a/PKGBUILD b/PKGBUILD
index 9958fb177baf..19b6e150ae6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,16 +10,17 @@ arch=(any)
url="https://github.com/quandyfactory/${_base}"
license=(GPL)
depends=(python)
+makedepends=(python-build python-installer python-setuptools python-wheel)
source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
sha512sums=('ac9d5b0f8acd0a18f918309cacba131843feebd6ad7c94935062d6e1ed7b529c5b91d6a9b65787647f73616e974d0599e8515bb07d69b036483d3a733e4dec6a')
build() {
cd ${_base}-${pkgver}
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
cd ${_base}-${pkgver}
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENCE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
}