summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenry Tung2022-05-15 03:40:32 -0700
committerHenry Tung2022-05-15 03:40:32 -0700
commit41f60f70d3048789e5a69e05a6937e487948ce48 (patch)
tree20a2491680951b47aabc0e1b17671531a0d560ef
downloadaur-41f60f70d3048789e5a69e05a6937e487948ce48.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8518d82cffb4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-didl-lite
+ pkgdesc = DIDL-Lite tools for Python to read and write DIDL-Lite-xml
+ pkgver = 1.3.2
+ pkgrel = 1
+ url = https://pypi.org/project/python-didl-lite
+ arch = any
+ license = Apache
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/p/python-didl-lite/python-didl-lite-1.3.2.tar.gz
+ sha256sums = 88c0641d3140f7b05f1efd93f7c481fc62aa50d1e05e17f0e0a15bee025c4af1
+
+pkgname = python-didl-lite
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ed0c5e4e3cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Henry Tung <compgamer89@gmail.com>
+pkgname=python-didl-lite
+_pkgname=${pkgname}
+pkgver=1.3.2
+pkgrel=1
+pkgdesc="DIDL-Lite tools for Python to read and write DIDL-Lite-xml"
+license=('Apache')
+arch=('any')
+url="https://pypi.org/project/${pkgname}"
+makedepends=(python-build python-installer python-wheel python-setuptools)
+depends=(python)
+source=(https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz)
+sha256sums=('88c0641d3140f7b05f1efd93f7c481fc62aa50d1e05e17f0e0a15bee025c4af1')
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}