summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2020-12-02 16:11:01 -0500
committerGuillaume Horel2020-12-02 16:12:26 -0500
commitcb4801a66862fc60b9fb620e473f1ff26768d614 (patch)
treeea23511b37a34af310246b80b81b57e7cf33f09a
downloadaur-cb4801a66862fc60b9fb620e473f1ff26768d614.tar.gz
initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2951c0506511
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-diffcp
+ pkgdesc = Differentiating through a cone program
+ pkgver = 1.0.15
+ pkgrel = 1
+ url = http://github.com/cvxgrp/diffcp/
+ arch = x86_64
+ license = Apache
+ checkdepends = python-pytest
+ makedepends = pybind11
+ depends = python-ecos
+ depends = python-numpy
+ depends = python-scs
+ depends = python-scipy
+ depends = python-threadpoolctl
+ source = python-diffcp-1.0.15.tar.gz::https://github.com/cvxgrp/diffcp/archive/v1.0.15.tar.gz
+ sha256sums = f8ce6f4f502271995c2aa67793f9d79e0c426cdd49ce257290877c2ee5f36877
+
+pkgname = python-diffcp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5c962aa0d6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname='python-diffcp'
+_module='diffcp'
+pkgver='1.0.15'
+pkgrel=1
+pkgdesc="Differentiating through a cone program"
+url="http://github.com/cvxgrp/diffcp/"
+depends=('python-ecos' 'python-numpy' 'python-scs' 'python-scipy' 'python-threadpoolctl')
+makedepends=('pybind11')
+optdepends=()
+checkdepends=('python-pytest')
+license=('Apache')
+arch=('x86_64')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/cvxgrp/diffcp/archive/v${pkgver}.tar.gz")
+sha256sums=('f8ce6f4f502271995c2aa67793f9d79e0c426cdd49ce257290877c2ee5f36877')
+
+build() {
+ cd "${_module}-${pkgver}"
+ MARCH_NATIVE=1 OPENMP_FLAGS="-fopenmp" python setup.py build
+}
+
+package() {
+ cd "${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+
+check() {
+ cd "${_module}-${pkgver}"
+ python setup.py build_ext --inplace
+ python tests.py
+}