summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip2022-04-05 14:23:43 +0800
committerPhilip2022-04-05 14:23:43 +0800
commitab63c0355840f2999ba5441d56913791f3d06b58 (patch)
tree9363de4b91cd674a1630cbca5a36277f0a5813fe
downloadaur-ab63c0355840f2999ba5441d56913791f3d06b58.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee299988dad4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-diffractio
+ pkgdesc = Optical Diffraction and Interference (scalar and vectorial)
+ pkgver = 0.0.13
+ pkgrel = 1
+ url = https://bitbucket.org/optbrea/diffractio/src/master/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python-pytest-runner
+ depends = python
+ depends = python-click
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-matplotlib
+ depends = python-nbsphinx
+ source = https://files.pythonhosted.org/packages/source/d/diffractio/diffractio-0.0.13.tar.gz
+ sha256sums = 5bfb2fa72a185aaab19c7d9b1f37a6f4617e28206bb6d6532c3fe399593e7fea
+
+pkgname = python-diffractio
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2f83bb0016e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Philip <philip1731 protonmail ch>
+
+pkgname=python-diffractio
+pkgver=0.0.13
+pkgrel=1
+pkgdesc='Optical Diffraction and Interference (scalar and vectorial)'
+arch=('any')
+url="https://bitbucket.org/optbrea/diffractio/src/master/"
+license=('MIT')
+depends=('python'
+ 'python-click'
+ 'python-numpy'
+ 'python-scipy'
+ 'python-matplotlib'
+ 'python-nbsphinx')
+makedepends=('python-setuptools'
+ 'python-pytest-runner')
+_name=${pkgname#python-}
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('5bfb2fa72a185aaab19c7d9b1f37a6f4617e28206bb6d6532c3fe399593e7fea')
+
+package() {
+ cd "${srcdir}/diffractio-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+