summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2022-09-06 12:40:36 +0200
committerAlexander F. Rødseth2022-09-06 12:40:36 +0200
commitf7e73f9d63c6f282d2577fd44b3cb19ea29f1d1b (patch)
tree25b3caed6abc075f691e33fb442728ce72c7afe6
downloadaur-f7e73f9d63c6f282d2577fd44b3cb19ea29f1d1b.tar.gz
Initial commit
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD21
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9f24fae62a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = python-diffusers
+ pkgdesc = Pretrained diffusion models
+ pkgver = 0.2.4
+ pkgrel = 1
+ url = https://pypi.org/project/diffusers
+ arch = x86_64
+ license = Apache License 2.0
+ source = python-diffusers-0.2.4::https://github.com/huggingface/diffusers/archive/refs/tags/v0.2.4.tar.gz
+ b2sums = 348a75f20ef36c44784d2235bc70ce35033d331dd384c382a3edbfadeac9ac3a6a24fc383421be32834eb81dc00feb035d2998dc511c4591580d10752c956261
+
+pkgname = python-diffusers
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09b99ade59b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=python-diffusers
+pkgver=0.2.4
+pkgrel=1
+pkgdesc='Pretrained diffusion models'
+arch=(x86_64)
+url='https://pypi.org/project/diffusers'
+license=('Apache License 2.0')
+source=("$pkgname-$pkgver::https://github.com/huggingface/diffusers/archive/refs/tags/v$pkgver.tar.gz")
+b2sums=('348a75f20ef36c44784d2235bc70ce35033d331dd384c382a3edbfadeac9ac3a6a24fc383421be32834eb81dc00feb035d2998dc511c4591580d10752c956261')
+
+build() {
+ cd diffusers-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd diffusers-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+}