summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Irofti2021-02-14 23:10:12 +0200
committerPaul Irofti2021-02-14 23:10:12 +0200
commit51edc3403977f16216d050355e0f07a5b8c64a0e (patch)
tree66a8a904fcc8c0e197acabae10dc3a8254f1326b
downloadaur-51edc3403977f16216d050355e0f07a5b8c64a0e.tar.gz
machine-learning on dirty categorical variables
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..969aa208e446
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python-dirty_cat-git
+ pkgdesc = machine-learning on dirty categorical variables
+ pkgver = 0.0.5.r203.g3c55029
+ pkgrel = 1
+ url = https://github.com/dirty-cat/dirty_cat
+ arch = any
+ license = BSD
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = python-joblib
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-scikit-learn
+ depends = python-requests
+ provides = python-dirty_cat
+ conflicts = python-dirty_cat
+ source = git+https://github.com/dirty-cat/dirty_cat.git
+ md5sums = SKIP
+
+pkgname = python-dirty_cat-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..863e292c90ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Paul Irofti <paul@irofti.net>
+
+pkgname="python-dirty_cat-git"
+pkgver=0.0.5.r203.g3c55029
+pkgrel=1
+pkgdesc="machine-learning on dirty categorical variables"
+url="https://github.com/dirty-cat/dirty_cat"
+depends=('python' 'python-joblib' 'python-numpy' 'python-scipy'
+ 'python-scikit-learn' 'python-requests')
+makedepends=('git' 'python-setuptools')
+provides=('python-dirty_cat')
+conflicts=('python-dirty_cat')
+arch=('any')
+license=('BSD')
+source=("git+https://github.com/dirty-cat/dirty_cat.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "dirty_cat"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "dirty_cat"
+ python setup.py build
+}
+
+package() {
+ cd "dirty_cat"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+# vim:ts=2:sw=2:et: