summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordolfies2021-08-06 22:22:41 -0400
committerdolfies2021-08-06 22:22:41 -0400
commitf0fb3f2d93c771564ff8df3c6cec0eda7a11f91a (patch)
tree5c0cbe878a3daa7686e886217b05bed8c98ecfed
downloadaur-f0fb3f2d93c771564ff8df3c6cec0eda7a11f91a.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b51709c7d5a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-discord-self
+ pkgdesc = A fork of the popular Discord.py for self-bots
+ pkgver = 1.9.0
+ pkgrel = 1
+ url = https://github.com/dolfies/discord.py-self
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-aiohttp
+ optdepends = python-pynacl: Voice support
+ optdepends = libffi: Voice support
+ source = discord.py-self-1.9.0.tar.gz::https://github.com/dolfies/discord.py-self/archive/v1.9.0.tar.gz
+ sha512sums = d56c3fc89075df0f098eae4bcfe6023190888e5fd26f9059e1f7e203cfeb30ae9045fcd2d2e29c6230f879f16d53fdf06eb66f8a300feaa58dd1abfd8954018d
+
+pkgname = python-discord-self
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3886a00fcf1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Dolfies <jeyalfie47+aur@gmail.com>
+pkgname=python-discord-self
+_pkgname=discord.py-self
+pkgver=1.9.0
+pkgrel=1
+pkgdesc="A fork of the popular Discord.py for self-bots"
+arch=(any)
+url="https://github.com/dolfies/discord.py-self"
+license=('MIT')
+depends=('python' 'python-aiohttp')
+makedepends=('python-setuptools')
+optdepends=('python-pynacl: Voice support'
+ 'libffi: Voice support')
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/dolfies/discord.py-self/archive/v${pkgver}.tar.gz")
+sha512sums=('d56c3fc89075df0f098eae4bcfe6023190888e5fd26f9059e1f7e203cfeb30ae9045fcd2d2e29c6230f879f16d53fdf06eb66f8a300feaa58dd1abfd8954018d')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}/" LICENSE
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}