summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Szczuczko2015-06-09 21:50:56 +0100
committerAlex Szczuczko2015-06-09 21:50:56 +0100
commit68beece573dbfc7eb617eea552663cf8f2a86ff6 (patch)
tree2b656de4190f951328b2d9ea8e3cef4b3aabe15c
downloadaur-68beece573dbfc7eb617eea552663cf8f2a86ff6.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD19
3 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5aff477ac68d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-ditail
+ pkgdesc = Tail for directories
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/ASzc/ditail
+ arch = any
+ license = GPL
+ depends = python-pyinotify
+ options = !emptydirs
+ source = https://github.com/ASzc/ditail/archive/0.1.0.tar.gz
+ sha256sums = 994e2f5bfd895e2b160518069ebc3c372efdd51a174c73341b93d23f2a502390
+
+pkgname = python-ditail
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1377554ebea6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0e3c187604c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Alex Szczuczko <alex@szc.ca>
+
+pkgname=python-ditail
+_pkgname=ditail
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Tail for directories"
+arch=("any")
+url="https://github.com/ASzc/$_pkgname"
+license=("GPL")
+depends=("python-pyinotify")
+options=(!emptydirs)
+source=("$url/archive/${pkgver}.tar.gz")
+sha256sums=("994e2f5bfd895e2b160518069ebc3c372efdd51a174c73341b93d23f2a502390")
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}