summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Hanna2015-09-12 15:09:27 +0200
committerSimon Hanna2015-09-12 15:09:27 +0200
commit6eedae875e8b6d72e451d9eaf74b24ae2699d50a (patch)
treeed27ef58a262f5bf1d1593ffd2311a40bea44c39
downloadaur-6eedae875e8b6d72e451d9eaf74b24ae2699d50a.tar.gz
Intial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..17a59a2a53c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-django-appconf
+ pkgdesc = A helper class for handling configuration defaults of packaged Django apps gracefully
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/jezdez-archive/django-appconf
+ arch = any
+ license = BSD
+ options = !emptydirs
+ source = https://github.com/jezdez-archive/django-appconf/archive/v1.0.1.tar.gz
+ sha256sums = 1574e5cbdc402d5e8e7b078513c1083a168c746282e50c06fbe10c98f97aee89
+
+pkgname = python-django-appconf
+ depends = python-django
+ depends = python-six
+
+pkgname = python2-django-appconf
+ depends = python2-django
+ depends = python2-six
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0639e694a424
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Simon Hanna <simon dot hanna AT serve-me DOT info>
+
+pkgname=('python-django-appconf' 'python2-django-appconf')
+_pkgbase='django-appconf'
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="A helper class for handling configuration defaults of packaged Django apps gracefully"
+arch=(any)
+url="https://github.com/jezdez-archive/django-appconf"
+license=('BSD')
+options=(!emptydirs)
+install=
+source=("https://github.com/jezdez-archive/django-appconf/archive/v${pkgver}.tar.gz")
+sha256sums=('1574e5cbdc402d5e8e7b078513c1083a168c746282e50c06fbe10c98f97aee89')
+
+
+package_python-django-appconf() {
+ depends=('python-django' 'python-six')
+ cd "$srcdir/$_pkgbase-$pkgver"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+package_python2-django-appconf() {
+ depends=('python2-django' 'python2-six')
+ cd "$srcdir/$_pkgbase-$pkgver"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: