summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgetzze2018-06-03 22:54:42 +0100
committergetzze2018-06-03 22:54:42 +0100
commit9ae53564d57118e2f5de8e4c1816c91bb3136c46 (patch)
tree14624808e50900cc1be87ce614870019f1e496e2
downloadaur-9ae53564d57118e2f5de8e4c1816c91bb3136c46.tar.gz
Initial commit version 4.0.6
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD27
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ae95211d3f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-django-cacheops
+ pkgdesc = A slick ORM cache with automatic granular event-driven invalidation
+ pkgver = 4.0.6
+ pkgrel = 1
+ url = https://github.com/Suor/django-cacheops
+ arch = any
+ license = custom
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ options = !emptydirs
+ source = python-django-cacheops-4.0.6.tar.gz::https://github.com/Suor/django-cacheops/archive/4.0.6.tar.gz
+ sha256sums = 799ce297d187f6a10523cfbc90434a5794fe2fa9a455b49f2f5b560f65e97626
+
+pkgname = python-django-cacheops
+ depends = python-django
+ depends = python-redis
+
+pkgname = python2-django-cacheops
+ depends = python2-django
+ depends = python2-redis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78515f927150
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: getzze <getzze at gmail dot com>
+
+pkgname=('python-django-cacheops' 'python2-django-cacheops')
+pkgver=4.0.6
+pkgrel=1
+pkgdesc="A slick ORM cache with automatic granular event-driven invalidation"
+arch=(any)
+url="https://github.com/Suor/django-cacheops"
+license=('custom')
+options=(!emptydirs)
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('799ce297d187f6a10523cfbc90434a5794fe2fa9a455b49f2f5b560f65e97626')
+makedepends=('python-setuptools' 'python2-setuptools')
+
+package_python-django-cacheops() {
+ depends=('python-django' 'python-redis')
+ cd "$srcdir/django-cacheops-$pkgver"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+package_python2-django-cacheops() {
+ depends=('python2-django' 'python2-redis')
+ cd "$srcdir/django-cacheops-$pkgver"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}