summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrazer2017-05-02 18:58:01 +0200
committerrazer2017-05-02 18:58:01 +0200
commit7fca0ce615753d1c8890405c843c9d43a52bb9de (patch)
tree3351dc90a44bf4a75c8e72116f14c992f30e8bae
downloadaur-7fca0ce615753d1c8890405c843c9d43a52bb9de.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5f994f818a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-django-channels
+ pkgdesc = Developer-friendly asynchrony for Django
+ pkgver = 1.1.3
+ pkgrel = 1
+ url = https://channels.readthedocs.io
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ depends = python-django
+ source = git://github.com/django/channels
+ md5sums = SKIP
+
+pkgname = python-django-channels
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f15f1a8f2e42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Razer <razer[AT]neuf[DOT]fr>
+
+pkgname=python-django-channels
+_pypi_pkgname=django-channels
+pkgver=1.1.3
+pkgrel=1
+pkgdesc="Developer-friendly asynchrony for Django"
+arch=(any)
+url="https://channels.readthedocs.io"
+license=('BSD')
+makedepends=('python-setuptools')
+depends=('python' 'python-django')
+source=("git://github.com/django/channels")
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/channels"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "${srcdir}/channels"
+ python setup.py install --root=${pkgdir} --optimize=1 || return 1
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}