summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgetzze2020-09-09 23:26:31 +0100
committergetzze2020-09-09 23:26:31 +0100
commit07f8f6715bc7e68dd98b79f8dc26d6be93454830 (patch)
tree852924eda7a8109ce4a35fdd6d08d39bcba13749
parentd6a9ee0668009f92eee591c7e5135f6fcaec9b20 (diff)
downloadaur-07f8f6715bc7e68dd98b79f8dc26d6be93454830.tar.gz
update 5.0.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 9 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a78c6fa8a7c..88e785f5c76a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
pkgbase = python-django-cleanup
pkgdesc = Automatically deletes old file for FileField and ImageField. It also deletes files on models instance deletion
- pkgver = 4.0.0
+ pkgver = 5.0.0
pkgrel = 1
url = https://github.com/un1t/django-cleanup
arch = any
license = MIT
makedepends = python-setuptools
- makedepends = python2-setuptools
+ depends = python-django
options = !emptydirs
- source = python-django-cleanup-4.0.0.tar.gz::https://github.com/un1t/django-cleanup/archive/4.0.0.tar.gz
- sha256sums = 776a76d21916a0b7bd4995297a8fbb4805e0d4f6f2c42662cf6cda2fa2fe22f1
+ source = python-django-cleanup-5.0.0.tar.gz::https://github.com/un1t/django-cleanup/archive/5.0.0.tar.gz
+ sha256sums = d1038ba64d7bd8cda183b5db22407dc09f3c787e0074e96910777989a759c093
pkgname = python-django-cleanup
- depends = python-django
-
-pkgname = python2-django-cleanup
- depends = python2-django
diff --git a/PKGBUILD b/PKGBUILD
index 91882db4025e..a024ff6ab272 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: getzze <getzze at gmail dot com>
-pkgname=('python-django-cleanup' 'python2-django-cleanup')
-pkgver=4.0.0
+pkgname='python-django-cleanup'
+pkgver=5.0.0
pkgrel=1
pkgdesc="Automatically deletes old file for FileField and ImageField. It also deletes files on models instance deletion"
arch=(any)
@@ -9,19 +9,13 @@ url="https://github.com/un1t/django-cleanup"
license=('MIT')
options=(!emptydirs)
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('776a76d21916a0b7bd4995297a8fbb4805e0d4f6f2c42662cf6cda2fa2fe22f1')
-makedepends=('python-setuptools' 'python2-setuptools')
+sha256sums=('d1038ba64d7bd8cda183b5db22407dc09f3c787e0074e96910777989a759c093')
+makedepends=('python-setuptools')
+depends=('python-django')
package_python-django-cleanup() {
- depends=('python-django')
cd "$srcdir/django-cleanup-$pkgver"
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
python setup.py install --root="$pkgdir/" --optimize=1
}
-package_python2-django-cleanup() {
- depends=('python2-django')
- cd "$srcdir/django-cleanup-$pkgver"
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- python2 setup.py install --root="$pkgdir/" --optimize=1
-}