summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgetzze2018-06-03 22:53:28 +0100
committergetzze2018-06-03 22:53:28 +0100
commita46e3dca42a04d255ec35c40d0b178bf02b21c3c (patch)
treee49edd87a704adca4c99a880fc990527e5accd31
downloadaur-a46e3dca42a04d255ec35c40d0b178bf02b21c3c.tar.gz
Initial commit version 2.1.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..86e80267ccad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-django-cleanup
+ pkgdesc = Automatically deletes old file for FileField and ImageField. It also deletes files on models instance deletion
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://github.com/un1t/django-cleanup
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ options = !emptydirs
+ source = python-django-cleanup-2.1.0.tar.gz::https://github.com/un1t/django-cleanup/archive/2.1.0.tar.gz
+ sha256sums = bee4d05411d91947493a6abcfe46a0429856471b73a1c3051683e2d422bd0176
+
+pkgname = python-django-cleanup
+ depends = python-django
+
+pkgname = python2-django-cleanup
+ depends = python2-django
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e87919224d6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: getzze <getzze at gmail dot com>
+
+pkgname=('python-django-cleanup' 'python2-django-cleanup')
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="Automatically deletes old file for FileField and ImageField. It also deletes files on models instance deletion"
+arch=(any)
+url="https://github.com/un1t/django-cleanup"
+license=('MIT')
+options=(!emptydirs)
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('bee4d05411d91947493a6abcfe46a0429856471b73a1c3051683e2d422bd0176')
+makedepends=('python-setuptools' 'python2-setuptools')
+
+package_python-django-cleanup() {
+ depends=('python-django')
+ cd "$srcdir/django-cleanup-$pkgver"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+package_python2-django-cleanup() {
+ depends=('python2-django')
+ cd "$srcdir/django-cleanup-$pkgver"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}