summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrazer2023-03-16 07:04:43 +0100
committerrazer2023-03-16 07:04:43 +0100
commit13278639ae7da8aae9019fbfc62f99c3d7a4564e (patch)
treed09429398ec91d1e5d7616a7cb0bb31be48bf43d
parentefb5a98ec1481dc7749d4675d13801de271ea694 (diff)
downloadaur-13278639ae7da8aae9019fbfc62f99c3d7a4564e.tar.gz
Switch to python installer
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17ef2d3d2507..ce449c6b59ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,13 @@
pkgbase = python-django-cors-headers
pkgdesc = Django application for handling the server headers required for Cross-Origin Resource Sharing (CORS)
pkgver = 3.14.0
- pkgrel = 1
+ pkgrel = 2
url = http://github.com/ottoyiu/django-cors-headers
arch = any
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools-scm
depends = python-django
source = https://pypi.io/packages/source/d/django_cors_headers/django_cors_headers-3.14.0.tar.gz
sha256sums = 5fbd58a6fb4119d975754b2bc090f35ec160a8373f276612c675b00e8a138739
diff --git a/PKGBUILD b/PKGBUILD
index 80971697eb67..3eb5632268e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,33 @@
-# Maintainer: Tom Hacohen <tom@stosb.com>
+# Maintainer: razer, razer at neuf dot fr
+# Past Maintainer: Tom Hacohen <tom@stosb.com>
# Past Maintainer: Miguel de Val-Borro <miguel at archlinux dot net>
+# Contributor: SZanko, szanko at protonmail dot com
pkgname=python-django-cors-headers
_pypi_pkgname=django_cors_headers
pkgver=3.14.0
-pkgrel=1
+pkgrel=2
pkgdesc="Django application for handling the server headers required for Cross-Origin Resource Sharing (CORS)"
arch=('any')
url="http://github.com/ottoyiu/django-cors-headers"
depends=('python-django')
-makedepends=('python-setuptools')
+makedepends=(
+'python-build'
+'python-installer'
+'python-wheel'
+'python-setuptools-scm'
+)
source=("https://pypi.io/packages/source/d/${_pypi_pkgname}/${_pypi_pkgname}-${pkgver}.tar.gz")
sha256sums=('5fbd58a6fb4119d975754b2bc090f35ec160a8373f276612c675b00e8a138739')
build() {
cd ${srcdir}/${_pypi_pkgname}-${pkgver}
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd ${srcdir}/${_pypi_pkgname}-${pkgver}
- python setup.py install --prefix=/usr --root=${pkgdir}
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -vDm644 -t "$pkgdir/usr/share/license/$pkgname" LICENSE
}