summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Ruhier2017-04-13 09:53:07 +0200
committerAnthony Ruhier2017-04-13 09:53:07 +0200
commit719295050d0b45df6189d40bb38115000980cb41 (patch)
tree1c325bb90089100a55ff50032fed29edb033b4ab
downloadaur-719295050d0b45df6189d40bb38115000980cb41.tar.gz
v1.7
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..774ce872dce5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-django-debug-toolbar
+ pkgdesc = A configurable set of panels that display various debug information about the current request/response.
+ pkgver = 1.7
+ pkgrel = 1
+ url = https://github.com/jazzband/django-debug-toolbar
+ arch = any
+ license = BSD-3
+ makedepends = python-django>=1.8
+ makedepends = python-setuptools
+ makedepends = python2-django>=1.8
+ makedepends = python2-setuptools
+ options = !emptydirs
+ source = https://github.com/jazzband/django-debug-toolbar/archive/1.7.tar.gz
+ sha256sums = c566d0afa5252288e2dc36c987c14d60ed4e1b684c8ae4413aa76fa4b1e78b14
+
+pkgname = python-django-debug-toolbar
+ depends = python-django>=1.8
+ depends = python-sqlparse
+
+pkgname = python2-django-debug-toolbar
+ depends = python2-django>=1.8
+ depends = python2-sqlparse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b691358e39e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Anthony25 <Anthony Ruhier>
+#
+# Thanks to Jeremy "Ichimonji10" Audet <ichimonji10 at gmail dot com> for
+# his PKGBUILD that served as a base for this one
+
+pkgbase=python-django-debug-toolbar
+_pkgbase="${pkgbase#python-}"
+pkgname=(python-django-debug-toolbar python2-django-debug-toolbar)
+pkgver=1.7
+pkgrel=1
+pkgdesc='A configurable set of panels that display various debug information about the current request/response.'
+arch=(any)
+url='https://github.com/jazzband/django-debug-toolbar'
+license=(BSD-3)
+makedepends=(
+ 'python-django>=1.8'
+ python-setuptools
+ 'python2-django>=1.8'
+ python2-setuptools
+)
+options=(!emptydirs)
+source=("https://github.com/jazzband/${_pkgbase}/archive/${pkgver}.tar.gz")
+sha256sums=('c566d0afa5252288e2dc36c987c14d60ed4e1b684c8ae4413aa76fa4b1e78b14')
+
+package_python-django-debug-toolbar() {
+ depends=('python-django>=1.8' 'python-sqlparse')
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+package_python2-django-debug-toolbar() {
+ depends=('python2-django>=1.8' 'python2-sqlparse')
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: