summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgetzze2018-06-03 22:48:36 +0100
committergetzze2018-06-03 22:48:36 +0100
commit9e96f3287da6f9711476331c27a724f10952c659 (patch)
tree5fd790fba44bd2d26dac205132bf6b8f0e9b9e10
downloadaur-9e96f3287da6f9711476331c27a724f10952c659.tar.gz
Initial commit version 1.5.1
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD27
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5e0ffbfdd5d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-django-dynamic-preferences
+ pkgdesc = Dynamic global and instance settings for your django project
+ pkgver = 1.5.1
+ pkgrel = 1
+ url = https://github.com/EliotBerriot/django-dynamic-preferences
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ options = !emptydirs
+ source = python-django-dynamic-preferences-1.5.1.tar.gz::https://github.com/EliotBerriot/django-dynamic-preferences/archive/1.5.1.tar.gz
+ sha256sums = f639e858139d4256967e4dd9421f442f929967e0ab573813944f3d6af60fea9d
+
+pkgname = python-django-dynamic-preferences
+ depends = python-wheel
+ depends = python-django
+ depends = python-persisting-theory
+
+pkgname = python2-django-dynamic-preferences
+ depends = python2-wheel
+ depends = python2-django
+ depends = python2-persisting-theory
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69f2ae52c088
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: getzze <getzze at gmail dot com>
+
+pkgname=('python-django-dynamic-preferences' 'python2-django-dynamic-preferences')
+pkgver=1.5.1
+pkgrel=1
+pkgdesc="Dynamic global and instance settings for your django project"
+arch=(any)
+url="https://github.com/EliotBerriot/django-dynamic-preferences"
+license=('BSD')
+options=(!emptydirs)
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('f639e858139d4256967e4dd9421f442f929967e0ab573813944f3d6af60fea9d')
+makedepends=('python-setuptools' 'python2-setuptools')
+
+package_python-django-dynamic-preferences() {
+ depends=('python-wheel' 'python-django' 'python-persisting-theory')
+ cd "$srcdir/django-dynamic-preferences-$pkgver"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+package_python2-django-dynamic-preferences() {
+ depends=('python2-wheel' 'python2-django' 'python2-persisting-theory')
+ cd "$srcdir/django-dynamic-preferences-$pkgver"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}