summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre-Alain TORET2019-03-13 17:53:25 +0100
committerPierre-Alain TORET2019-03-13 17:53:25 +0100
commit511f84dc2d23c8f2939fe55a260cf61beedd9dc7 (patch)
tree9c62820bb7f11bf046a84bd656ccb912f47883e4
downloadaur-511f84dc2d23c8f2939fe55a260cf61beedd9dc7.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e1b7b441cca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-django-etesync-journal
+ pkgdesc = The server side implementation of the EteSync protocol.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://pypi.org/project/django-etesync-journal/
+ arch = any
+ license = AGPL3
+ makedepends = python-setuptools
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/source/d/django-etesync-journal/django-etesync-journal-1.0.0.tar.gz
+ sha256sums = 107aa607b6491fc614ab98a0c75f7849caf89f6fe9ad4f5a7173c2565274d437
+
+pkgname = python-django-etesync-journal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b936f994067
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Pierre-Alain TORET <pierre-alain.toret@protonmail.com>
+pkgname=('python-django-etesync-journal')
+_name=${pkgname#python-}
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="The server side implementation of the EteSync protocol."
+arch=(any)
+url="https://pypi.org/project/django-etesync-journal/"
+license=('AGPL3')
+options=(!emptydirs)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('107aa607b6491fc614ab98a0c75f7849caf89f6fe9ad4f5a7173c2565274d437')
+makedepends=('python-setuptools')
+
+build() {
+ cd ${srcdir}/$_name-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd ${srcdir}/$_name-${pkgver}
+ python setup.py install --prefix=/usr --root=${pkgdir}
+}