summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorŁukasz Pożarlik2018-03-03 12:47:44 +0100
committerŁukasz Pożarlik2018-03-03 12:47:44 +0100
commitbbad2235e483dd3b747514bab35e8a688b68eea6 (patch)
treece2e9f0d1099f1e4c830f063737a0d32e1944523
downloadaur-bbad2235e483dd3b747514bab35e8a688b68eea6.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2ae6b5b6c10
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-django-location-field
+ pkgdesc = Let users pick locations using a map widget and store its latitude and longitude
+ pkgver = 2.0.3
+ pkgrel = 1
+ url = https://github.com/caioariede/django-location-field
+ arch = any
+ license = MIT
+ makedepends = python
+ makedepends = python-setuptools
+ makedepends = python2
+ makedepends = python2-setuptools
+ source = https://files.pythonhosted.org/packages/source/d/django-location-field/django-location-field-2.0.3.tar.gz
+ sha256sums = 981c3743b03856f22ede1039ab567df6af08852acce9359b62ecc3eca9253d39
+
+pkgname = python-django-location-field
+ depends = python-django
+
+pkgname = python2-django-location-field
+ depends = python2-django
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b76bed4fad13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Łukasz Pożarlik <lpozarlik@gmail.com>
+
+pkgname=('python-django-location-field' 'python2-django-location-field')
+pkgdesc="Let users pick locations using a map widget and store its latitude and longitude"
+pkgver=2.0.3
+pkgrel=1
+url="https://github.com/caioariede/django-location-field"
+license=('MIT')
+arch=('any')
+makedepends=('python'
+ 'python-setuptools'
+ 'python2'
+ 'python2-setuptools')
+source=("https://files.pythonhosted.org/packages/source/d/django-location-field/django-location-field-${pkgver}.tar.gz")
+sha256sums=('981c3743b03856f22ede1039ab567df6af08852acce9359b62ecc3eca9253d39')
+
+build() {
+ cp -r ${srcdir}/django-location-field-${pkgver} ${srcdir}/django-location-field-${pkgver}-py2
+
+ cd ${srcdir}/django-location-field-${pkgver}
+ python setup.py build
+
+ cd ${srcdir}/django-location-field-${pkgver}-py2
+ python2 setup.py build
+}
+
+package_python-django-location-field() {
+ depends=('python-django')
+ cd ${srcdir}/django-location-field-${pkgver}
+ python setup.py install --prefix=/usr --root=${pkgdir}
+ install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+}
+
+package_python2-django-location-field() {
+ depends=('python2-django')
+ cd ${srcdir}/django-location-field-${pkgver}-py2
+ python2 setup.py install --prefix=/usr --root=${pkgdir}
+ install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+}
+
+# vim:set ts=2 sw=2 et:
+