summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Daube2020-06-01 13:47:38 +0200
committerJulian Daube2020-06-01 13:47:38 +0200
commit51177cdf87be33d62380e60e87b750166a6bf5e2 (patch)
treef02767aba2974f377300cf4552e3456cc2997f27
parent5c5d17a4e4e190fef48e808a8e2a3b3df2442589 (diff)
downloadaur-51177cdf87be33d62380e60e87b750166a6bf5e2.tar.gz
fix license, add description
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00a57d533522..5b6318ba3ee4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,10 @@
pkgbase = python-django-markdownx-git
+ pkgdesc = Comprehensive Markdown plugin built for Django
pkgver = 1.0
pkgrel = 1
- url = https://neutronx.github.io/django-markdownx/
+ url = https://github.com/neutronX/django-markdownx
arch = any
+ license = bsd
makedepends = python-setuptools
depends = python
depends = python-django
diff --git a/PKGBUILD b/PKGBUILD
index 66ff06fa51f8..968e3fefe494 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,14 @@
pkgname="python-django-markdownx-git"
pkgver=1.0
pkgrel=1
-
+pkgdesc="Comprehensive Markdown plugin built for Django"
arch=("any")
-url="https://neutronx.github.io/django-markdownx/"
+url="https://github.com/neutronX/django-markdownx"
+license=("bsd")
provides=("python-django-markdownx")
-source=("$pkgname::git+https://github.com/neutronX/django-markdownx")
+source=("$pkgname::git+$url")
depends=("python" "python-django" "python-pillow" "python-markdown")
makedepends=("python-setuptools")
@@ -28,6 +29,8 @@ build() {
package() {
cd $pkgname
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/python-django-markdownx/LICENSE
}
md5sums=("SKIP")