summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid McInnis2016-02-03 22:59:39 -0800
committerDavid McInnis2016-02-03 22:59:39 -0800
commitdb4aa3508c0cb019b8a6285dee286e8d39977958 (patch)
treef0b49087ec23b039c35ff61bac1e2ea3b8eada91
downloadaur-db4aa3508c0cb019b8a6285dee286e8d39977958.tar.gz
first commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfa885b3c7fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Feb 4 06:59:29 UTC 2016
+pkgbase = python-django-model-utils
+ pkgdesc = Django model mixins and utilities
+ pkgver = 2.4
+ pkgrel = 1
+ url = https://github.com/carljm/django-model-utils/
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-django
+ source = https://pypi.python.org/packages/source/d/django-model-utils/django-model-utils-2.4.tar.gz
+ md5sums = 6bef27d0ef53a2132b86825921c3b0da
+
+pkgname = python-django-model-utils
+ depends = python-django
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d16f15cb181
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+#Maintainer: David McInnis<davidm@eagles.ewu.edu>
+
+pkgbase=('python-django-model-utils')
+pkgname=('python-django-model-utils')
+_module='django-model-utils'
+pkgver='2.4'
+pkgrel=1
+pkgdesc="Django model mixins and utilities"
+url="https://github.com/carljm/django-model-utils/"
+depends=('python-django')
+makedepends=('python-setuptools')
+license=('BSD')
+arch=('any')
+source=("https://pypi.python.org/packages/source/d/django-model-utils/django-model-utils-${pkgver}.tar.gz")
+md5sums=('6bef27d0ef53a2132b86825921c3b0da')
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}