summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Ruhier2020-05-16 08:23:11 +0000
committerAnthony Ruhier2020-05-16 08:23:11 +0000
commitf74ad1898e6981fdb56b41793b592395da0b9198 (patch)
tree53b440b37d791fcaef6db668c8fb3425227afd58
parent8d24ef9eb0b6ec51fc60f87ccc4c82e8b5f03359 (diff)
downloadaur-f74ad1898e6981fdb56b41793b592395da0b9198.tar.gz
v0.11.0
Drop python 2 support
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 10 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce8e6dd0ece0..629cf0c3a5db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,16 @@
pkgbase = python-django-mptt
pkgdesc = Utilities for implementing a modified pre-order traversal tree in django.
- pkgver = 0.9.0
+ pkgver = 0.11.0
pkgrel = 1
url = https://github.com/django-mptt/django-mptt
arch = any
license = BSD
- makedepends = python-django>=1.8
+ makedepends = python-django>=3.0
makedepends = python-setuptools
- makedepends = python2-django>=1.8
- makedepends = python2-setuptools
+ depends = python-django>=3.0
options = !emptydirs
- source = https://github.com/django-mptt/django-mptt/archive/0.9.0.tar.gz
- sha256sums = 7235f1f3d6b53979eca4d27b7c5bd49e15475dba5326a653598799853b3d4f2a
+ source = https://github.com/django-mptt/django-mptt/archive/0.11.0.tar.gz
+ sha256sums = acbecfc6d56c53f894a2e28d15aef9d922f21c0a4976a5a2e48855f420ee976e
pkgname = python-django-mptt
- depends = python-django>=1.8
-
-pkgname = python2-django-mptt
- depends = python2-django>=1.8
diff --git a/PKGBUILD b/PKGBUILD
index 24e8b3ebbe58..845a3bc40e73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,35 +5,26 @@
pkgbase=python-django-mptt
_pkgbase="${pkgbase#python-}"
-pkgname=(python-django-mptt python2-django-mptt)
-pkgver=0.9.0
+pkgname=python-django-mptt
+pkgver=0.11.0
pkgrel=1
pkgdesc="Utilities for implementing a modified pre-order traversal tree in django."
arch=(any)
url='https://github.com/django-mptt/django-mptt'
license=(BSD)
makedepends=(
- 'python-django>=1.8'
+ 'python-django>=3.0'
python-setuptools
- 'python2-django>=1.8'
- python2-setuptools
)
+depends=('python-django>=3.0')
options=(!emptydirs)
source=("https://github.com/django-mptt/${_pkgbase}/archive/${pkgver}.tar.gz")
-sha256sums=('7235f1f3d6b53979eca4d27b7c5bd49e15475dba5326a653598799853b3d4f2a')
+sha256sums=('acbecfc6d56c53f894a2e28d15aef9d922f21c0a4976a5a2e48855f420ee976e')
package_python-django-mptt() {
- depends=('python-django>=1.8')
cd "${srcdir}/${_pkgbase}-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-package_python2-django-mptt() {
- depends=('python2-django>=1.8')
- cd "${srcdir}/${_pkgbase}-${pkgver}"
- python2 setup.py install --root="${pkgdir}/" --optimize=1
- install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}
-
# vim:set ts=2 sw=2 et: