summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Wojdyła2022-09-08 20:19:55 +0200
committerMichał Wojdyła2022-09-08 20:19:55 +0200
commit19b4bbbe255be2d8f73b232f2457d2c7021325b7 (patch)
tree9f1cfbad62134a483ca033a01676e0c3abbdce02
parent4b47daed28769695296ccf2a4d5a4666c4542fce (diff)
downloadaur-19b4bbbe255be2d8f73b232f2457d2c7021325b7.tar.gz
enable check
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c7d080cb992..462315111a97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = python-django-otp
pkgdesc = A pluggable framework for adding two-factor authentication to Django using one-time passwords
pkgver = 1.1.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/django-otp/django-otp
arch = any
license = BSD
+ checkdepends = python-tox
makedepends = python-setuptools
- depends = python
depends = python-django
optdepends = python-qrcode: For OTP setup with QR code
- source = django-otp-1.1.3.tar.gz::https://files.pythonhosted.org/packages/source/d/django-otp/django-otp-1.1.3.tar.gz
- sha512sums = 19dd7899afe9e275209176e878879467bbfd72e272be88878d4c862af9627f2beb6359619284210db3cbe98d51057fbbd13e7c5999a69a6034502c742bf2c808
+ source = django-otp-1.1.3.tar.gz::https://github.com/django-otp/django-otp/archive/refs/tags/v1.1.3.tar.gz
+ sha512sums = 4e8b38c393fe29b2fa91e3f1f70abd2cc671dcf760e2e2bf8f738e04fc43a6e7f54229f298f7f2611988dffc40b4450ed1ab910ce9e9995b205dff1b3c90a977
pkgname = python-django-otp
diff --git a/PKGBUILD b/PKGBUILD
index 8c9bb8d5d412..cb6248b7334c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,28 @@ _name=django-otp
pkgbase=python-django-otp
pkgname=('python-django-otp')
pkgver=1.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="A pluggable framework for adding two-factor authentication to Django using one-time passwords"
url="https://github.com/django-otp/django-otp"
license=('BSD')
arch=('any')
optdepends=('python-qrcode: For OTP setup with QR code')
makedepends=('python-setuptools')
-depends=('python' 'python-django')
-source=("${_name}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-$pkgver.tar.gz")
-sha512sums=('19dd7899afe9e275209176e878879467bbfd72e272be88878d4c862af9627f2beb6359619284210db3cbe98d51057fbbd13e7c5999a69a6034502c742bf2c808')
+depends=('python-django')
+checkdepends=('python-tox')
+source=("${_name}-${pkgver}.tar.gz::https://github.com/${_name}/${_name}/archive/refs/tags/v$pkgver.tar.gz")
+sha512sums=('4e8b38c393fe29b2fa91e3f1f70abd2cc671dcf760e2e2bf8f738e04fc43a6e7f54229f298f7f2611988dffc40b4450ed1ab910ce9e9995b205dff1b3c90a977')
build() {
cd "$srcdir/${_name}-${pkgver}"
python setup.py build
}
+check() {
+ cd "$srcdir/${_name}-${pkgver}"
+ tox -e py310
+}
+
package() {
cd "$srcdir/${_name}-${pkgver}/"