summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Moch2019-03-08 19:25:39 -0500
committerDaniel Moch2019-03-08 19:25:39 -0500
commit9a49e18555ee1551cbb919c12ed3d5c752b47492 (patch)
tree2b4bb2e5d2e1b2bde3515e6ffd24c0079b2043a0
parentd7d8d6edc08f5aa5901ddfe9b657fc33378f0cd2 (diff)
downloadaur-9a49e18555ee1551cbb919c12ed3d5c752b47492.tar.gz
upgpkg: python-django-otp 0.5.2-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6eefff1f946..f7b459e9ddd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = python-django-otp
pkgdesc = A framework for adding two-factor authentication to Django using one-time passwords
- pkgver = 0.5.1
- pkgrel = 2
+ pkgver = 0.5.2
+ pkgrel = 1
url = https://bitbucket.org/psagers/django-otp
arch = any
license = BSD
makedepends = python-setuptools
makedepends = python2-setuptools
optdepends = python-qrcode: For OTP setup with QR code
- source = django-otp-0.5.1.tar.gz::https://files.pythonhosted.org/packages/source//django-otp/django-otp-0.5.1.tar.gz
- source = django-otp-0.5.1.tar.gz.asc::https://files.pythonhosted.org/packages/source//django-otp/django-otp-0.5.1.tar.gz.asc
+ source = django-otp-0.5.2.tar.gz::https://files.pythonhosted.org/packages/source/d/django-otp/django-otp-0.5.2.tar.gz
+ source = django-otp-0.5.2.tar.gz.asc::https://files.pythonhosted.org/packages/source/d/django-otp/django-otp-0.5.2.tar.gz.asc
validpgpkeys = 21024EE045D76BF8758F7A5B8B14DEF5236837D8
- sha256sums = 529f936e9b6acbb011ac575d2e7e1a6c823661627ebcb314c11cd721237da433
+ sha256sums = 5756050ec09ecf8e6ce2b0f9f370ebd26249f326a1010a413b61c6a4c554f25f
sha256sums = SKIP
pkgname = python-django-otp
diff --git a/PKGBUILD b/PKGBUILD
index 8aab383dbcee..040ec55a4359 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
_name=django-otp
pkgbase=python-django-otp
pkgname=('python-django-otp' 'python2-django-otp')
-pkgver=0.5.1
-pkgrel=2
+pkgver=0.5.2
+pkgrel=1
pkgdesc="A framework for adding two-factor authentication to Django using one-time passwords"
url="https://bitbucket.org/psagers/django-otp"
license=('BSD')
arch=('any')
optdepends=('python-qrcode: For OTP setup with QR code')
makedepends=('python-setuptools' 'python2-setuptools')
-source=("${_name}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_name}/${_name}-$pkgver.tar.gz"
- "${_name}-${pkgver}.tar.gz.asc::https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_name}/${_name}-$pkgver.tar.gz.asc")
+source=("${_name}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-$pkgver.tar.gz"
+ "${_name}-${pkgver}.tar.gz.asc::https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-$pkgver.tar.gz.asc")
validpgpkeys=('21024EE045D76BF8758F7A5B8B14DEF5236837D8')
-sha256sums=('529f936e9b6acbb011ac575d2e7e1a6c823661627ebcb314c11cd721237da433'
+sha256sums=('5756050ec09ecf8e6ce2b0f9f370ebd26249f326a1010a413b61c6a4c554f25f'
'SKIP')
prepare() {
@@ -31,14 +31,14 @@ build() {
package_python-django-otp() {
depends=('python' 'python-django' )
cd "$srcdir/${_name}-${pkgver}/"
- python setup.py install --root="$pkgdir/" --optimize=1
+ python setup.py install --skip-build --root="$pkgdir/" --optimize=1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
package_python2-django-otp() {
depends=('python2' 'python2-django' )
cd "$srcdir/${_name}-${pkgver}-py2/"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+ python2 setup.py install --skip-build --root="$pkgdir/" --optimize=1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}