summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Moch2018-03-11 16:15:10 -0400
committerDaniel Moch2018-03-11 16:15:10 -0400
commitb2eba2c49131e848fd96d62ca1a52bffb18e5a19 (patch)
tree98b734e52864fcdc354ef18b26427ae45deb2641
downloadaur-b2eba2c49131e848fd96d62ca1a52bffb18e5a19.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f9521168639
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-django-otp
+ pkgdesc = A framework for adding two-factor authentication to Django using one-time passwords
+ pkgver = 0.4.3
+ pkgrel = 1
+ url = https://bitbucket.org/psagers/django-otp
+ arch = any
+ license = BSD
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python
+ depends = python-django
+ optdepends = python-qrcode: For OTP setup with QR code
+ source = django-otp-0.4.3.tar.gz::https://pypi.python.org/packages/07/70/21b67af8b22f4cf4dd99bc3ebb5a9891488392ab26b17c3e62e2dea76c41/django-otp-0.4.3.tar.gz#md5=5b078961be8b9b48207dc30710991df4
+ sha512sums = 3f3ec761dc12ed40e8c757dfbe1fd951c7c6aed3abc311c823acdeca08d5864b54c8442a49807228be17b30c20093b1ba7fb8b2c0f86f00dc1cc215ccd7c28de
+
+pkgname = python-django-otp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71af16da5e21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Daniel Moch <daniel AT danielmoch DOT com>
+
+pkgname=python-django-otp
+pkgver=0.4.3
+pkgrel=1
+pkgdesc="A framework for adding two-factor authentication to Django using one-time passwords"
+url="https://bitbucket.org/psagers/django-otp"
+license=('BSD')
+arch=('any')
+depends=('python' 'python-django' )
+optdepends=('python-qrcode: For OTP setup with QR code')
+makedepends=('python' 'python-setuptools')
+source=(django-otp-$pkgver.tar.gz::https://pypi.python.org/packages/07/70/21b67af8b22f4cf4dd99bc3ebb5a9891488392ab26b17c3e62e2dea76c41/django-otp-$pkgver.tar.gz#md5=5b078961be8b9b48207dc30710991df4)
+sha512sums=('3f3ec761dc12ed40e8c757dfbe1fd951c7c6aed3abc311c823acdeca08d5864b54c8442a49807228be17b30c20093b1ba7fb8b2c0f86f00dc1cc215ccd7c28de')
+
+build() {
+ cd "$srcdir/django-otp-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/django-otp-${pkgver}/"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: ts=2 sts=2 sw=2 et ft=PKGBUILD